summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 14:26:58 +0100
committerRemi Collet <remi@php.net>2021-12-07 14:26:58 +0100
commit95ec2dd882cb0d8c89fef977e3906df5b9b20191 (patch)
tree7dd77e0abde51b4b888068d1816282a08b92caed
parentbd791ed87aa341b02c91ccf65e6dda2e8af80b91 (diff)
update to 3.5.0 (no change)
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-math.spec14
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 9b7c5a5..af1f8b9 100644
--- a/composer.json
+++ b/composer.json
@@ -26,8 +26,7 @@
},
"require": {
"php": "^7.3 || ~8.0.0 || ~8.1.0",
- "ext-mbstring": "*",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "ext-mbstring": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -60,7 +59,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-math": "^3.2.0"
+ "conflict": {
+ "zendframework/zend-math": "*"
}
}
diff --git a/php-laminas-math.spec b/php-laminas-math.spec
index 208d3cd..7487215 100644
--- a/php-laminas-math.spec
+++ b/php-laminas-math.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 79f6453a47a5774cf3736c5c66cb4818486681da
+%global gh_commit 146d8187ab247ae152e811a6704a953d43537381
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-math
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.4.0
+Version: 3.5.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -60,8 +60,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-# "ext-mbstring": "*",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "ext-mbstring": "*"
Requires: php(language) >= 7.3
Requires: php-mbstring
# remirepo:1
@@ -154,7 +153,7 @@ if [ "$(id -un)" != "remi" ]; then
filter="--filter '^((?!(testRandFloat)).)*$'"
fi
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -186,6 +185,11 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Mon Oct 11 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0