summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-24 07:52:32 +0200
committerRemi Collet <remi@remirepo.net>2021-09-24 07:52:32 +0200
commit5913e4c35bfc97806d653022c87324c9c915cc1e (patch)
tree07a4896bb02ca3e5dc6c60c79c97f6c659ae94c5
parent4edb200bc09cb8824ae522d0f890fe5bbd5cf27c (diff)
update to 2.14.3
-rw-r--r--composer.json2
-rw-r--r--php-laminas-mail.spec26
2 files changed, 24 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index 81d9976..3439c6d 100644
--- a/composer.json
+++ b/composer.json
@@ -39,9 +39,11 @@
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-config": "^3.4",
"laminas/laminas-crypt": "^2.6 || ^3.0",
+ "laminas/laminas-db": "^2.12",
"laminas/laminas-servicemanager": "^3.2.1",
"phpunit/phpunit": "^9.3",
"psalm/plugin-phpunit": "^0.15.1",
+ "symfony/process": "^5.3",
"vimeo/psalm": "^4.7"
},
"suggest": {
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index 4783c38..a850b09 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit 180c6c7baa37cba16fe9fd34af0f346e796cf1a1
+%global gh_commit a496ab1c708b91809de211522057a6d6781bd0aa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mail
@@ -18,7 +18,7 @@
%global library Mail
Name: php-%{gh_project}
-Version: 2.14.1
+Version: 2.14.3
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -49,14 +49,19 @@ BuildRequires: (php-composer(true/punycode) >= 2.1
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-config": "^3.4",
# "laminas/laminas-crypt": "^2.6 || ^3.0",
+# "laminas/laminas-db": "^2.12",
# "laminas/laminas-servicemanager": "^3.2.1",
# "phpunit/phpunit": "^9.3"
# "psalm/plugin-phpunit": "^0.15.1",
+# "symfony/process": "^5.3",
# "vimeo/psalm": "^4.7"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.0 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.12 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-# remirepo:11
+# ignore min version
+BuildRequires: (php-composer(symfony/process) >= 4 with php-composer(symfony/process) < 6)
+# remirepo:13
%else
BuildRequires: php-laminas-loader
BuildRequires: php-laminas-mime
@@ -66,7 +71,9 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-true-punycode
BuildRequires: php-laminas-config3
BuildRequires: php-laminas-crypt
+BuildRequires: php-laminas-db
BuildRequires: php-laminas-servicemanager
+BuildRequires: php-symfony4-process
%endif
BuildRequires: phpunit9 >= 9.3
%global phpunit %{_bindir}/phpunit9
@@ -192,6 +199,11 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Config3/autoload.php',
+ '%{php_home}/%{namespace}/Db/autoload.php',
+ [
+ '%{php_home}/Symfony5/Component/Process/autoload.php',
+ '%{php_home}/Symfony4/Component/Process/autoload.php',
+ ],
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -203,11 +215,14 @@ exit (class_exists("\\Zend\\%{library}\\Message") ? 0 : 1);
'
: upstream test suite
+# testCanUseTraversableAsSpec use Composer\\InstalledVersions
ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --filter '^((?!(testCanUseTraversableAsSpec)).)*$' \
+ || ret=1
fi
done
exit $ret
@@ -227,6 +242,9 @@ exit $ret
%changelog
+* Thu Sep 23 2021 Remi Collet <remi@remirepo.net> - 2.14.3-1
+- update to 2.14.3
+
* Thu May 20 2021 Remi Collet <remi@remirepo.net> - 2.14.1-1
- update to 2.14.1