summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-20 08:39:08 +0200
committerRemi Collet <remi@remirepo.net>2021-05-20 08:39:08 +0200
commit4edb200bc09cb8824ae522d0f890fe5bbd5cf27c (patch)
tree8952ebdeb7944ff860579a84d6d156ec46e56e88
parenta08c983ef53edae17f069d4d877587f1465685a7 (diff)
update to 2.14.1
-rw-r--r--composer.json6
-rw-r--r--php-laminas-mail.spec9
2 files changed, 12 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index f5ee58c..81d9976 100644
--- a/composer.json
+++ b/composer.json
@@ -40,7 +40,9 @@
"laminas/laminas-config": "^3.4",
"laminas/laminas-crypt": "^2.6 || ^3.0",
"laminas/laminas-servicemanager": "^3.2.1",
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^9.3",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.7"
},
"suggest": {
"laminas/laminas-crypt": "Crammd5 support in SMTP Auth",
@@ -59,10 +61,12 @@
"scripts": {
"check": [
"@cs-check",
+ "@static-analysis",
"@test"
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index b41aac7..4783c38 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit 542686aebf480c6902ad7f08b52498e94818bc0a
+%global gh_commit 180c6c7baa37cba16fe9fd34af0f346e796cf1a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mail
@@ -18,7 +18,7 @@
%global library Mail
Name: php-%{gh_project}
-Version: 2.14.0
+Version: 2.14.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -51,6 +51,8 @@ BuildRequires: (php-composer(true/punycode) >= 2.1
# "laminas/laminas-crypt": "^2.6 || ^3.0",
# "laminas/laminas-servicemanager": "^3.2.1",
# "phpunit/phpunit": "^9.3"
+# "psalm/plugin-phpunit": "^0.15.1",
+# "vimeo/psalm": "^4.7"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.0 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
@@ -225,6 +227,9 @@ exit $ret
%changelog
+* Thu May 20 2021 Remi Collet <remi@remirepo.net> - 2.14.1-1
+- update to 2.14.1
+
* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0