summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 14:26:07 +0200
committerRemi Collet <remi@php.net>2022-10-17 14:26:07 +0200
commitebe39496f329571a926d66d86df37b5d01221fc5 (patch)
tree5c3504f1a0306d24b253b78b7d6d565cb27e632f
parentd77df1cf035db386a72188c8444c89df9580815e (diff)
update to 2.9.0 (no change)HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json11
-rw-r--r--php-laminas-loader.spec24
2 files changed, 21 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 8457d67..15891a3 100644
--- a/composer.json
+++ b/composer.json
@@ -16,14 +16,17 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.2.1",
- "phpunit/phpunit": "^9.3"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "~9.5.25"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-loader.spec b/php-laminas-loader.spec
index 4cf6e5c..5c3b0ec 100644
--- a/php-laminas-loader.spec
+++ b/php-laminas-loader.spec
@@ -1,12 +1,12 @@
# remirepo/Fedora spec file for php-laminas-loader
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit d0589ec9dd48365fd95ad10d1c906efd7711c16b
+%global gh_commit 51ed9c3fa42d1098a9997571730c0cbf42d078d3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-loader
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -29,7 +29,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -38,17 +38,17 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
BuildRequires: php-laminas-zendframework-bridge
%endif
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.2.1",
-# "phpunit/phpunit": "^9.3"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.25"
%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.3
+# "php": "- raise dependency on PHP 7.3"
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -121,7 +121,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -151,6 +151,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0 (no change)
+- raise dependency on PHP 8.0
+
* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- keep compatibility using laminas-zendframework-bridge