summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 09:03:00 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 09:03:00 +0200
commitd77df1cf035db386a72188c8444c89df9580815e (patch)
tree22081051c726a4cba3fbe17720b69fa2a5b1642a
parentb4623bd48c02e9da56b14807a716de809e249c74 (diff)
update to 2.8.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json9
-rw-r--r--php-laminas-loader.spec16
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 06f7b42..8457d67 100644
--- a/composer.json
+++ b/composer.json
@@ -19,11 +19,10 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.2.1",
"phpunit/phpunit": "^9.3"
},
"autoload": {
@@ -46,7 +45,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-loader": "^2.6.1"
+ "conflict": {
+ "zendframework/zend-loader": "*"
}
}
diff --git a/php-laminas-loader.spec b/php-laminas-loader.spec
index 5ff8327..4cf6e5c 100644
--- a/php-laminas-loader.spec
+++ b/php-laminas-loader.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit bcf8a566cb9925a2e7cc41a16db09235ec9fb616
+%global gh_commit d0589ec9dd48365fd95ad10d1c906efd7711c16b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-loader
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -38,7 +38,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
BuildRequires: php-laminas-zendframework-bridge
%endif
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.2.1",
# "phpunit/phpunit": "^9.3"
%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit9 >= 9.3
@@ -47,8 +47,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -122,7 +121,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -152,6 +151,11 @@ exit $ret
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0
- raise dependency on PHP 7.3