summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 09:00:27 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 09:00:27 +0200
commitc8385f79bf86276c5a3aea8f9287d24a6aea3cf6 (patch)
tree8860753e8815d6068df3ee946aca9c19ddb3aecb
parent023c701b0f2d3bb269cadfbe31ebd5c7611fe2d9 (diff)
update to 3.3.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json9
-rw-r--r--php-laminas-json.spec16
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index ecb2314..5301998 100644
--- a/composer.json
+++ b/composer.json
@@ -19,11 +19,10 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.2.1",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1",
"phpunit/phpunit": "^9.3"
},
@@ -51,7 +50,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-json": "^3.1.2"
+ "conflict": {
+ "zendframework/zend-json": "*"
}
}
diff --git a/php-laminas-json.spec b/php-laminas-json.spec
index 946264e..e7e88f1 100644
--- a/php-laminas-json.spec
+++ b/php-laminas-json.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1e3b64d3b21dac0511e628ae8debc81002d14e3c
+%global gh_commit 9a0ce9f330b7d11e70c4acb44d67e8c4f03f437f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
+Version: 3.3.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -48,7 +48,7 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "^2.2.1",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
# "phpunit/phpunit": "^9.3"
BuildRequires: phpunit9 >= 9.3
@@ -64,8 +64,7 @@ BuildRequires: php-laminas-stdlib >= 3.1
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -155,7 +154,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -184,6 +183,11 @@ exit $ret
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- raise dependency on PHP 7.3