summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-15 15:34:55 +0100
committerRemi Collet <remi@remirepo.net>2021-02-15 15:34:55 +0100
commit023c701b0f2d3bb269cadfbe31ebd5c7611fe2d9 (patch)
tree1c08864b50efec0dc4752f16ffb0dbd64d323772
parent37a6d0a83cd07372c31dc0a5b037d05fc1c58a4a (diff)
update to 3.2.0HEADmaster
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json12
-rw-r--r--php-laminas-json.spec32
2 files changed, 22 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 28ca659..ecb2314 100644
--- a/composer.json
+++ b/composer.json
@@ -18,20 +18,14 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "3.1.x-dev",
- "dev-develop": "3.2.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1",
- "phpunit/phpunit": "^5.7.23 || ^6.4.3"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-json-server": "For implementing JSON-RPC servers",
@@ -58,6 +52,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-json": "self.version"
+ "zendframework/zend-json": "^3.1.2"
}
}
diff --git a/php-laminas-json.spec b/php-laminas-json.spec
index 1ae13a9..946264e 100644
--- a/php-laminas-json.spec
+++ b/php-laminas-json.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-json
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 00dc0da7b5e5018904c5c4a8e80a5faa16c2c1c6
+%global gh_commit 1e3b64d3b21dac0511e628ae8debc81002d14e3c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.1.2
-Release: 2%{?dist}
+Version: 3.2.0
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -50,8 +50,8 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3"
-BuildRequires: phpunit6 >= 6.4.3
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-stdlib) >= 3.1 with php-composer(%{gh_owner}/laminas-stdlib) < 4)
@@ -64,9 +64,9 @@ BuildRequires: php-laminas-stdlib >= 3.1
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -92,8 +92,8 @@ Requires: php-composer(fedora/autoloader)
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.1.2-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.1.3
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -155,9 +155,9 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
done
@@ -174,6 +174,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -183,6 +184,11 @@ exit $ret
%changelog
+* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.1.2-2
- cleanup