summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 15:04:30 +0200
committerRemi Collet <remi@php.net>2022-10-17 15:04:30 +0200
commitc1dbf1984e838d060965bf30587796d850639e09 (patch)
treec9d56c65b70faefc2841a63bf88daa95c016e66e
parentc8385f79bf86276c5a3aea8f9287d24a6aea3cf6 (diff)
update to 3.5.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json11
-rw-r--r--php-laminas-json.spec24
2 files changed, 21 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 5301998..bf2ac5d 100644
--- a/composer.json
+++ b/composer.json
@@ -16,15 +16,18 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-coding-standard": "~2.4.0",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1",
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^9.5.25"
},
"suggest": {
"laminas/laminas-json-server": "For implementing JSON-RPC servers",
diff --git a/php-laminas-json.spec b/php-laminas-json.spec
index e7e88f1..ed0a256 100644
--- a/php-laminas-json.spec
+++ b/php-laminas-json.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-json
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9a0ce9f330b7d11e70c4acb44d67e8c4f03f437f
+%global gh_commit 7a8a1d7bf2d05dd6c1fbd7c0868d3848cf2b57ec
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.0
+Version: 3.5.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -48,10 +48,10 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "^2.2.1",
+# "laminas/laminas-coding-standard": "^2.4.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
-# "phpunit/phpunit": "^9.3"
-BuildRequires: phpunit9 >= 9.3
+# "phpunit/phpunit": "^9.5.25"
+BuildRequires: phpunit9 >= 9.5.25
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-stdlib) >= 3.1 with php-composer(%{gh_owner}/laminas-stdlib) < 4)
@@ -64,8 +64,8 @@ BuildRequires: php-laminas-stdlib >= 3.1
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-Requires: php(language) >= 7.3
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -154,7 +154,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php73 php74 php80 php81; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -183,6 +183,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+- raise dependency on PHP 8.0
+
* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- keep compatibility using laminas-zendframework-bridge