summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-12 09:58:18 +0200
committerRemi Collet <remi@php.net>2022-10-12 09:58:18 +0200
commitfd56182119d495584e53d099f10b79d48504aadd (patch)
tree71d53825140a26ec12c3a6ba38e3f3b68f3585b3
parent0289060b321290f7436a273996381b01c2791b72 (diff)
update to 2.22.0
raise dependency on PHP 8.0
-rw-r--r--composer.json11
-rw-r--r--php-laminas-inputfilter.spec30
2 files changed, 20 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 224584e..59f7573 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -31,7 +31,7 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-filter": "^2.13",
"laminas/laminas-servicemanager": "^3.16.0",
"laminas/laminas-stdlib": "^3.0",
@@ -40,11 +40,10 @@
"require-dev": {
"ext-json": "*",
"laminas/laminas-coding-standard": "~2.4.0",
- "laminas/laminas-db": "^2.15.0",
- "phpunit/phpunit": "^9.5.24",
+ "phpunit/phpunit": "^9.5.25",
"psalm/plugin-phpunit": "^0.17.0",
- "psr/http-message": "^1.0",
- "vimeo/psalm": "^4.27.0",
+ "psr/http-message": "^1.0.1",
+ "vimeo/psalm": "^4.28",
"webmozart/assert": "^1.11"
},
"suggest": {
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index 4b3585e..fedd43f 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8668227246d19564f339643f0f2aedcdff66612b
+%global gh_commit 2e9a2f2b867eb423338a9948ae0027ec4e556378
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.21.0
+Version: 2.22.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-json
BuildRequires: php-spl
# remirepo:1
@@ -47,23 +47,20 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "require-dev": {
# "ext-json": "*",
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-db": "^2.15.0",
-# "phpunit/phpunit": "^9.5.24",
+# "phpunit/phpunit": "^9.5.25",
# "psalm/plugin-phpunit": "^0.17.0",
-# "psr/http-message": "^1.0",
-# "vimeo/psalm": "^4.27.0",
+# "psr/http-message": "^1.0.1",
+# "vimeo/psalm": "^4.28",
# "webmozart/assert": "^1.11"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.15 with php-autoloader(%{gh_owner}/laminas-db) < 3)
-BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(webmozart/assert) >= 1.11 with php-composer(webmozart/assert) < 2)
-# remirepo:10
+# remirepo:9
%else
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-db
BuildRequires: php-psr-http-message
BuildRequires: php-webmozart-assert
%endif
@@ -73,12 +70,12 @@ BuildRequires: phpunit9 >= 9.5.24
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-filter": "^2.13",
# "laminas/laminas-servicemanager": "^3.16.0",
# "laminas/laminas-stdlib": "^3.0",
# "laminas/laminas-validator": "^2.15"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -168,7 +165,6 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/Db/autoload.php',
'%{php_home}/Webmozart/Assert/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
@@ -182,7 +178,7 @@ exit (class_exists("\\Zend\\%{library}\\Input") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php74 php80 php81 php82; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--filter '^((?!(testProvidesExpectedConfiguration|testFactoryWillCreateInputWithSuggestedFilters)).)*$' \
@@ -205,6 +201,10 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 2.22.0-1
+- update to 2.22.0
+- raise dependency on PHP 8.0
+
* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.21.0-1
- update to 2.21.0
- raise dependency on zend-servicemanager 3.16