summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-20 17:09:14 +0200
committerRemi Collet <remi@php.net>2022-09-20 17:09:14 +0200
commit0289060b321290f7436a273996381b01c2791b72 (patch)
tree96e9d093e384811c33f824f76f3dd2660b2c4c99
parent988a9b769d5e4b6fb6688c8f8e45510f80c18887 (diff)
update to 2.21.0
raise dependency on zend-servicemanager 3.16
-rw-r--r--composer.json13
-rw-r--r--php-laminas-inputfilter.spec39
2 files changed, 34 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index d77041e..224584e 100644
--- a/composer.json
+++ b/composer.json
@@ -33,17 +33,19 @@
"require": {
"php": "^7.4 || ~8.0.0 || ~8.1.0",
"laminas/laminas-filter": "^2.13",
- "laminas/laminas-servicemanager": "^3.12.0",
+ "laminas/laminas-servicemanager": "^3.16.0",
"laminas/laminas-stdlib": "^3.0",
"laminas/laminas-validator": "^2.15"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
- "laminas/laminas-db": "^2.13.4",
- "phpunit/phpunit": "^9.5.21",
+ "ext-json": "*",
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "laminas/laminas-db": "^2.15.0",
+ "phpunit/phpunit": "^9.5.24",
"psalm/plugin-phpunit": "^0.17.0",
"psr/http-message": "^1.0",
- "vimeo/psalm": "^4.24.0"
+ "vimeo/psalm": "^4.27.0",
+ "webmozart/assert": "^1.11"
},
"suggest": {
"psr/http-message-implementation": "PSR-7 is required if you wish to validate PSR-7 UploadedFileInterface payloads"
@@ -61,6 +63,7 @@
"scripts": {
"check": [
"@cs-check",
+ "@static-analysis",
"@test"
],
"cs-check": "phpcs",
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index b52d306..4b3585e 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f570c504bbecf81eda13e2cee45c1e945d07f1ec
+%global gh_commit 8668227246d19564f339643f0f2aedcdff66612b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.19.0
+Version: 2.21.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -35,24 +35,28 @@ BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 7.4
+BuildRequires: php-json
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.16.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "laminas/laminas-db": "^2.13.4",
-# "phpunit/phpunit": "^9.5.21",
+# "ext-json": "*",
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-db": "^2.15.0",
+# "phpunit/phpunit": "^9.5.24",
# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-message": "^1.0",
-# "vimeo/psalm": "^4.24.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13.4 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+# "vimeo/psalm": "^4.27.0",
+# "webmozart/assert": "^1.11"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.15 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-# remirepo:9
+BuildRequires: (php-composer(webmozart/assert) >= 1.11 with php-composer(webmozart/assert) < 2)
+# remirepo:10
%else
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-servicemanager
@@ -61,8 +65,9 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-db
BuildRequires: php-psr-http-message
+BuildRequires: php-webmozart-assert
%endif
-BuildRequires: phpunit9 >= 9.5.21
+BuildRequires: phpunit9 >= 9.5.24
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -70,7 +75,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-filter": "^2.13",
-# "laminas/laminas-servicemanager": "^3.12.0",
+# "laminas/laminas-servicemanager": "^3.16.0",
# "laminas/laminas-stdlib": "^3.0",
# "laminas/laminas-validator": "^2.15"
Requires: php(language) >= 7.3
@@ -78,7 +83,7 @@ Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.16 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -164,6 +169,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Db/autoload.php',
+ '%{php_home}/Webmozart/Assert/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -179,7 +185,7 @@ ret=0
for cmd in php php74 php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
- --filter '^((?!(testProvidesExpectedConfiguration)).)*$' \
+ --filter '^((?!(testProvidesExpectedConfiguration|testFactoryWillCreateInputWithSuggestedFilters)).)*$' \
--verbose || ret=1
fi
done
@@ -199,6 +205,13 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.21.0-1
+- update to 2.21.0
+- raise dependency on zend-servicemanager 3.16
+
+* Tue Jul 26 2022 Remi Collet <remi@remirepo.net> - 2.19.1-1
+- update to 2.19.1
+
* Thu Jul 21 2022 Remi Collet <remi@remirepo.net> - 2.19.0-1
- update to 2.19.0