summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-09 07:50:31 +0200
committerRemi Collet <remi@php.net>2022-06-09 07:50:31 +0200
commit76291982038a940a39d286abbf7eafd2f8931c3b (patch)
treebb39eace0ccb05b2e16c0ab435c3c8001ed9b82f
parentf3c345ac2cb18b70b89c1655bfbd778d26ca9d0a (diff)
update to 2.15.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-inputfilter.spec11
2 files changed, 14 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index b90bd41..6d8ae2c 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"laminas": {
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index 1b75dbb..edd84e2 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-inputfilter
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6124b3678051b792d1444be689cf9370531593a6
+%global gh_commit 14dca8785b9d78ddfef725942854d9c8e81405b9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.13.0
+Version: 2.15.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -183,7 +183,7 @@ exit (class_exists("\\Zend\\%{library}\\Input") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php74 php80 php81; do
+for cmd in php php74 php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--filter '^((?!(testProvidesExpectedConfiguration)).)*$' \
@@ -206,6 +206,9 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jun 9 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+
* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.13.0-1
- update to 2.13.0
- keep compatibility using laminas-zendframework-bridge