summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-03 08:03:22 +0100
committerRemi Collet <remi@php.net>2021-12-03 08:03:22 +0100
commitf3c345ac2cb18b70b89c1655bfbd778d26ca9d0a (patch)
tree01507e56e61aa03e880e751622a29a9d083f8f14
parentf72c2b89eba9c99447cafb25abf85a9166e3daf1 (diff)
update to 2.13.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on PHP 7.4 raise dependency on laminas-filter 2.13 raise dependency on laminas-validator 2.15
-rw-r--r--composer.json18
-rw-r--r--php-laminas-inputfilter.spec38
2 files changed, 33 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 2497bc2..b90bd41 100644
--- a/composer.json
+++ b/composer.json
@@ -25,18 +25,18 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-filter": "^2.9.1",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "laminas/laminas-filter": "^2.13",
"laminas/laminas-servicemanager": "^3.3.1",
"laminas/laminas-stdlib": "^3.0",
- "laminas/laminas-validator": "^2.11",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-validator": "^2.15"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-db": "^2.12",
+ "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-db": "^2.13.4",
+ "phpspec/prophecy": "^1.14",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.4.2",
+ "phpunit/phpunit": "^9.5.5",
"psalm/plugin-phpunit": "^0.15.1",
"psr/http-message": "^1.0",
"vimeo/psalm": "^4.6"
@@ -65,7 +65,7 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
"static-analysis": "psalm --shepherd --stats"
},
- "replace": {
- "zendframework/zend-inputfilter": "^2.10.1"
+ "conflict": {
+ "zendframework/zend-inputfilter": "*"
}
}
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index e7eeb96..1b75dbb 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 461a7a27b70bd440f925a31221b7a5348cd0d0fd
+%global gh_commit 6124b3678051b792d1444be689cf9370531593a6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.1
+Version: 2.13.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,25 +34,27 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.11 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-db": "^2.12",
+# "laminas/laminas-coding-standard": "~2.2.1",
+# "laminas/laminas-db": "^2.13.4",
+# "phpspec/prophecy": "^1.14",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.4.2",
# "psalm/plugin-phpunit": "^0.15.1",
# "psr/http-message": "^1.0",
# "vimeo/psalm": "^4.6"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.12 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13.4 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-composer(phpspec/prophecy) >= 1.14 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:10
%else
@@ -71,20 +73,19 @@ BuildRequires: phpunit9 >= 9.4.2
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-filter": "^2.9.1",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "laminas/laminas-filter": "^2.13",
# "laminas/laminas-servicemanager": "^3.3.1",
# "laminas/laminas-stdlib": "^3.0",
-# "laminas/laminas-validator": "^2.11",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-validator": "^2.15"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.11 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:7
%else
@@ -168,6 +169,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Db/autoload.php',
+ '%{php_home}/Prophecy/autoload.php',
'%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
@@ -204,6 +206,14 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on PHP 7.4
+- raise dependency on laminas-filter 2.13
+- raise dependency on laminas-validator 2.15
+
* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 2.12.1-1
- update to 2.12.1