summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-04 10:36:41 +0200
committerRemi Collet <remi@php.net>2022-04-04 10:36:41 +0200
commit78717ad3662c5aa2dbc6c430fc783ce8a932b35a (patch)
treed95c4a343b678b387d5b5cec75c92c9f9ffa6560
parent2f3cc564fa4b34086e68b1d2ab6bc4fc5cbc1b25 (diff)
update to 2.15.0
-rw-r--r--composer.json6
-rw-r--r--php-laminas-i18n.spec11
2 files changed, 11 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 151b1a8..5b4f80b 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,8 @@
"php": "7.4.99"
},
"allow-plugins": {
- "dealerdirect/phpcodesniffer-composer-installer": true
+ "dealerdirect/phpcodesniffer-composer-installer": true,
+ "composer/package-versions-deprecated": true
}
},
"extra": {
@@ -45,13 +46,14 @@
"laminas/laminas-filter": "^2.10.0",
"laminas/laminas-servicemanager": "^3.7.0",
"laminas/laminas-validator": "^2.14.0",
- "laminas/laminas-view": "^2.12.0",
+ "laminas/laminas-view": "^2.20.0",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.3",
"psalm/plugin-phpunit": "^0.16.1",
"vimeo/psalm": "^4.21"
},
"conflict": {
+ "laminas/laminas-view": "<2.20.0",
"phpspec/prophecy": "<1.9.0",
"zendframework/zend-i18n": "*"
},
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index e455903..ae3b5a3 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit 1fa15c41b683bedb2a846af54491868ddc73db38
+%global gh_commit 1654fcd6cd27c01a902b47fe71fa583ad227268c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.14.0
+Version: 2.15.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -47,7 +47,7 @@ BuildRequires: php-spl
# "laminas/laminas-filter": "^2.10.0",
# "laminas/laminas-servicemanager": "^3.7.0",
# "laminas/laminas-validator": "^2.14.0",
-# "laminas/laminas-view": "^2.12.0",
+# "laminas/laminas-view": "^2.20.0",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.3",
# "psalm/plugin-phpunit": "^0.16.1",
@@ -64,7 +64,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.10 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.14 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.20 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:14
@@ -253,6 +253,9 @@ exit $ret
%changelog
+* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+
* Tue Feb 22 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0
- raise dependency on PHP 7.4