summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-22 14:34:31 +0100
committerRemi Collet <remi@php.net>2022-02-22 14:34:31 +0100
commit2f3cc564fa4b34086e68b1d2ab6bc4fc5cbc1b25 (patch)
treed06e52d03843eeef3240dab5d2b20fa483137dd3
parent95d83c11473158659dd5817f2291728426ae8e0a (diff)
update to 2.14.0
raise dependency on PHP 7.4
-rw-r--r--.gitignore2
-rw-r--r--composer.json18
-rw-r--r--php-laminas-i18n.spec30
3 files changed, 37 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index ab21839..151b1a8 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"laminas": {
@@ -25,7 +31,7 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"ext-intl": "*",
"laminas/laminas-stdlib": "^2.7 || ^3.0"
},
@@ -33,14 +39,17 @@
"laminas/laminas-cache": "^3.1.2",
"laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
"laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-config": "^3.4.0",
"laminas/laminas-eventmanager": "^3.4.0",
"laminas/laminas-filter": "^2.10.0",
"laminas/laminas-servicemanager": "^3.7.0",
"laminas/laminas-validator": "^2.14.0",
"laminas/laminas-view": "^2.12.0",
- "phpunit/phpunit": "^9.3"
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.3",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.21"
},
"conflict": {
"phpspec/prophecy": "<1.9.0",
@@ -73,6 +82,7 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index 1c4e810..e455903 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-i18n
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit b3a55d05818ed37ed18e76c103727e95e32cf591
+%global gh_commit 1fa15c41b683bedb2a846af54491868ddc73db38
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.13.0
+Version: 2.14.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -31,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-intl
@@ -41,14 +41,17 @@ BuildRequires: php-spl
# "laminas/laminas-cache": "^3.1.2",
# "laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
# "laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-config": "^3.4.0",
# "laminas/laminas-eventmanager": "^3.4.0",
# "laminas/laminas-filter": "^2.10.0",
# "laminas/laminas-servicemanager": "^3.7.0",
# "laminas/laminas-validator": "^2.14.0",
# "laminas/laminas-view": "^2.12.0",
-# "phpunit/phpunit": "^9.3"
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.3",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.21"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -63,7 +66,8 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.10
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.14 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
-# remirepo:13
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:14
%else
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
@@ -76,6 +80,7 @@ BuildRequires: php-laminas-filter
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-view
%endif
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3
@@ -84,10 +89,10 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-intl": "*",
# "laminas/laminas-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
Requires: php-intl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -203,6 +208,9 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
+]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -245,6 +253,10 @@ exit $ret
%changelog
+* Tue Feb 22 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- raise dependency on PHP 7.4
+
* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.13.0-1
- update to 2.13.0 (no change)