summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-20 16:35:02 +0200
committerRemi Collet <remi@php.net>2022-09-20 16:35:02 +0200
commit725a39ff7b27e161874afcf0808c063eaf2595f4 (patch)
treeb7d29efa3ad44405c6198cc36a80f7b6dfbf5c06
parent1768a60e9d1d8ebcba218c88559ded71e13950ba (diff)
update to 2.18.0
raise dependency on PHP 8.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-i18n.spec30
2 files changed, 18 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index ad58386..9c6a410 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true,
@@ -32,7 +32,7 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0",
"ext-intl": "*",
"laminas/laminas-servicemanager": "^3.14.0",
"laminas/laminas-stdlib": "^2.7 || ^3.0"
@@ -41,13 +41,12 @@
"laminas/laminas-cache": "^3.1.2",
"laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
"laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
- "laminas/laminas-coding-standard": "~2.3.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"laminas/laminas-config": "^3.4.0",
"laminas/laminas-eventmanager": "^3.5.0",
"laminas/laminas-filter": "^2.16.0",
"laminas/laminas-validator": "^2.17.0",
"laminas/laminas-view": "^2.21.0",
- "phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5.21",
"psalm/plugin-phpunit": "^0.17.0",
"vimeo/psalm": "^4.24.0"
@@ -63,7 +62,6 @@
"laminas/laminas-eventmanager": "You should install this package to use the events in the translator",
"laminas/laminas-filter": "You should install this package to use the provided filters",
"laminas/laminas-i18n-resources": "This package provides validator and captcha translations",
- "laminas/laminas-servicemanager": "You should install this package to use the translator",
"laminas/laminas-validator": "You should install this package to use the provided validators",
"laminas/laminas-view": "You should install this package to use the provided view helpers"
},
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index 82499a2..4599c89 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit e77c04c050b7744125d26e213b2639c86d4514ad
+%global gh_commit ba4c7a12e0ff63a033aa16d4aa061ea09bda7f98
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.16.0
+Version: 2.18.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -31,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-intl
@@ -41,13 +41,12 @@ BuildRequires: php-spl
# "laminas/laminas-cache": "^3.1.2",
# "laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
# "laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
-# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "laminas/laminas-config": "^3.4.0",
# "laminas/laminas-eventmanager": "^3.5.0",
# "laminas/laminas-filter": "^2.16.0",
# "laminas/laminas-validator": "^2.17.0",
# "laminas/laminas-view": "^2.21.0",
-# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.5.21",
# "psalm/plugin-phpunit": "^0.17.0",
# "vimeo/psalm": "^4.24.0"
@@ -65,8 +64,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.16
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.17 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.21 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:14
+# remirepo:13
%else
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
@@ -79,7 +77,6 @@ BuildRequires: php-laminas-filter
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-view
%endif
-BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.21
@@ -88,11 +85,11 @@ BuildRequires: phpunit9 >= 9.5.21
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0",
# "ext-intl": "*",
# "laminas/laminas-servicemanager": "^3.14.0",
# "laminas/laminas-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
Requires: php-intl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -105,7 +102,6 @@ Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-eventmanager": "You should install this package to use the events in the translator",
# "laminas/laminas-filter": "You should install this package to use the provided filters",
# "laminas/laminas-i18n-resources": "Translation resources",
-# "laminas/laminas-servicemanager": "Laminas\\ServiceManager component",
# "laminas/laminas-validator": "You should install this package to use the provided validators",
# "laminas/laminas-view": "You should install this package to use the provided view helpers"
Suggests: php-autoloader(%{gh_owner}/laminas-cache)
@@ -209,9 +205,6 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Prophecy/PhpUnit/autoload.php',
-]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -230,7 +223,7 @@ rm -rf test/Validator/
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -254,6 +247,13 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.18.0-1
+- update to 2.18.0
+- raise dependency on PHP 8.0
+
+* Thu Jul 28 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0 (no change)
+
* Wed Jul 13 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
- update to 2.16.0
- add dependency on laminas-servicemanager