summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-13 07:42:31 +0200
committerRemi Collet <remi@php.net>2022-07-13 07:42:31 +0200
commit1768a60e9d1d8ebcba218c88559ded71e13950ba (patch)
tree51a78d10ce81b9b8e3a22eda1afcd75012c8f7c6
parent78717ad3662c5aa2dbc6c430fc783ce8a932b35a (diff)
update to 2.16.0
add dependency on laminas-servicemanager
-rw-r--r--composer.json16
-rw-r--r--php-laminas-i18n.spec45
2 files changed, 33 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index 5b4f80b..ad58386 100644
--- a/composer.json
+++ b/composer.json
@@ -34,6 +34,7 @@
"require": {
"php": "^7.4 || ~8.0.0 || ~8.1.0",
"ext-intl": "*",
+ "laminas/laminas-servicemanager": "^3.14.0",
"laminas/laminas-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
@@ -42,15 +43,14 @@
"laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
"laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-config": "^3.4.0",
- "laminas/laminas-eventmanager": "^3.4.0",
- "laminas/laminas-filter": "^2.10.0",
- "laminas/laminas-servicemanager": "^3.7.0",
- "laminas/laminas-validator": "^2.14.0",
- "laminas/laminas-view": "^2.20.0",
+ "laminas/laminas-eventmanager": "^3.5.0",
+ "laminas/laminas-filter": "^2.16.0",
+ "laminas/laminas-validator": "^2.17.0",
+ "laminas/laminas-view": "^2.21.0",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.3",
- "psalm/plugin-phpunit": "^0.16.1",
- "vimeo/psalm": "^4.21"
+ "phpunit/phpunit": "^9.5.21",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24.0"
},
"conflict": {
"laminas/laminas-view": "<2.20.0",
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index ae3b5a3..82499a2 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit 1654fcd6cd27c01a902b47fe71fa583ad227268c
+%global gh_commit e77c04c050b7744125d26e213b2639c86d4514ad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.15.0
+Version: 2.16.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -43,28 +43,27 @@ BuildRequires: php-spl
# "laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-config": "^3.4.0",
-# "laminas/laminas-eventmanager": "^3.4.0",
-# "laminas/laminas-filter": "^2.10.0",
-# "laminas/laminas-servicemanager": "^3.7.0",
-# "laminas/laminas-validator": "^2.14.0",
-# "laminas/laminas-view": "^2.20.0",
+# "laminas/laminas-eventmanager": "^3.5.0",
+# "laminas/laminas-filter": "^2.16.0",
+# "laminas/laminas-validator": "^2.17.0",
+# "laminas/laminas-view": "^2.21.0",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.3",
-# "psalm/plugin-phpunit": "^0.16.1",
-# "vimeo/psalm": "^4.21"
+# "phpunit/phpunit": "^9.5.21",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# ignore version as cache v3 not available
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.5 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.10 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.14 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.20 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.16 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.17 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.21 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:14
@@ -83,7 +82,7 @@ BuildRequires: php-laminas-view
BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.21
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -91,11 +90,13 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-intl": "*",
+# "laminas/laminas-servicemanager": "^3.14.0",
# "laminas/laminas-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 7.4
Requires: php-intl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
@@ -112,11 +113,11 @@ Suggests: php-autoloader(%{gh_owner}/laminas-config)
Suggests: php-autoloader(%{gh_owner}/laminas-eventmanager)
Suggests: php-autoloader(%{gh_owner}/laminas-filter)
Suggests: php-autoloader(%{gh_owner}/laminas-i18n-resources)
-Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
Suggests: php-autoloader(%{gh_owner}/laminas-validator)
Suggests: php-autoloader(%{gh_owner}/laminas-view)
-# remirepo:4
+# remirepo:5
%else
+Requires: php-laminas-servicemanager
Requires: php-laminas-stdlib
Requires: php-laminas-zendframework-bridge
%endif
@@ -165,6 +166,7 @@ phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
@@ -175,7 +177,6 @@ cat << 'EOF' | tee -a src/autoload.php
],
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Filter/autoload.php',
- '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Validator/autoload.php',
'%{php_home}/%{namespace}/View/autoload.php',
'%{php_home}/%{namespace}/I18n/Translator/Resources.php',
@@ -229,7 +230,7 @@ rm -rf test/Validator/
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -253,6 +254,10 @@ exit $ret
%changelog
+* Wed Jul 13 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- add dependency on laminas-servicemanager
+
* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0