summaryrefslogtreecommitdiffstats
path: root/php-laminas-i18n-resources.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-07 09:25:23 +0100
committerRemi Collet <remi@remirepo.net>2020-01-07 09:25:23 +0100
commit0b79da281687b8175f3bddcf4db6f879049b4f4b (patch)
tree3a6c26283f0d4eef3d029a3e18dad22b33b3d770 /php-laminas-i18n-resources.spec
parentca01ebb1ad1ac9ae8adb98b2242df67a6c44bca6 (diff)
switch to Laminas
Diffstat (limited to 'php-laminas-i18n-resources.spec')
-rw-r--r--php-laminas-i18n-resources.spec97
1 files changed, 69 insertions, 28 deletions
diff --git a/php-laminas-i18n-resources.spec b/php-laminas-i18n-resources.spec
index f608c8e..b03feb2 100644
--- a/php-laminas-i18n-resources.spec
+++ b/php-laminas-i18n-resources.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-i18n-resources
+# remirepo/Fedora spec file for php-laminas-i18n-resources
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3a2f5a246779f05d4fe0c47738d4d2271e484aee
+%global gh_commit 7585cd3a4f9656814425b35689919a220c73834b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-i18n-resources
+%global gh_owner laminas
+%global gh_project laminas-i18n-resources
+%global zf_name zend-i18n-resources
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Translator
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.6.1
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: Laminas Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -33,40 +35,53 @@ BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 5.6
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
-# "zendframework/zend-coding-standard": "~1.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
-# remirepo:4
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:3
%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: phpunit >= 5.7.27
+BuildRequires: php-laminas-zendframework-bridge
%endif
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0"
+# "php": "^5.6 || ^7.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:3
+%else
+Requires: php-laminas-zendframework-bridge
+%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.6.1
# None
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.6.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-This "component" provides translation resources, specifically
-for zendframework/zend-validate and zendframework/zend-captcha,
-for use with zendframework/zend-i18n's Translator subcomponent.
+%{gh_project} provides translation resources, specifically
+for laminas-validate and laminas-captcha,
+for use with laminas-i18n's Translator subcomponent.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -79,28 +94,49 @@ mv LICENSE.md LICENSE
: Create autoloader
phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(__DIR__))) . '/%{namespace}/I18n/%{library}/autoload.php',
+]);
+EOF
+
%install
-mkdir -p %{buildroot}%{php_home}/Zend/I18n
-cp -pr src %{buildroot}%{php_home}/Zend/I18n/%{library}
-cp -pr languages %{buildroot}%{php_home}/Zend/I18n/languages
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/I18n
+cp -pr src %{buildroot}%{php_home}/%{namespace}/I18n/%{library}
+cp -pr languages %{buildroot}%{php_home}/%{namespace}/I18n/languages
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/I18n/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php
+
%check
%if %{with_tests}
mkdir vendor
cat << EOF | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/I18n/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php";
+return (class_exists("\\Zend\\I18n\\%{library}\\Resources") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -115,10 +151,15 @@ exit $ret
%doc composer.json
%dir %{php_home}/Zend/I18n
%{php_home}/Zend/I18n/%{library}
- %{php_home}/Zend/I18n/languages
+%dir %{php_home}/%{namespace}/I18n
+ %{php_home}/%{namespace}/I18n/%{library}
+ %{php_home}/%{namespace}/I18n/languages
%changelog
+* Tue Jan 7 2020 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- switch to Laminas
+
* Tue Jun 25 2019 Remi Collet <remi@remirepo.net> - 2.6.1-1
- update to 2.6.1