summaryrefslogtreecommitdiffstats
path: root/php-laminas-i18n-resources.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-07 09:03:43 +0100
committerRemi Collet <remi@remirepo.net>2020-01-07 09:03:43 +0100
commitca01ebb1ad1ac9ae8adb98b2242df67a6c44bca6 (patch)
tree67a57045fb33d7d467a54b3cf22c3945af99a259 /php-laminas-i18n-resources.spec
duplicate ZF
Diffstat (limited to 'php-laminas-i18n-resources.spec')
-rw-r--r--php-laminas-i18n-resources.spec137
1 files changed, 137 insertions, 0 deletions
diff --git a/php-laminas-i18n-resources.spec b/php-laminas-i18n-resources.spec
new file mode 100644
index 0000000..f608c8e
--- /dev/null
+++ b/php-laminas-i18n-resources.spec
@@ -0,0 +1,137 @@
+# remirepo/Fedora spec file for php-zendframework-zend-i18n-resources
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 3a2f5a246779f05d4fe0c47738d4d2271e484aee
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-i18n-resources
+%global php_home %{_datadir}/php
+%global library Translator
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.6.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:4
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: phpunit >= 5.7.27
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.1
+# None
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+This "component" provides translation resources, specifically
+for zendframework/zend-validate and zendframework/zend-captcha,
+for use with zendframework/zend-i18n's Translator subcomponent.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/I18n
+cp -pr src %{buildroot}%{php_home}/Zend/I18n/%{library}
+cp -pr languages %{buildroot}%{php_home}/Zend/I18n/languages
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << EOF | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php';
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/Zend/I18n
+ %{php_home}/Zend/I18n/%{library}
+ %{php_home}/Zend/I18n/languages
+
+
+%changelog
+* Tue Jun 25 2019 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- update to 2.6.1
+
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+- run upstream test suite
+
+* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.5.2-5
+- switch from zend-loader to fedora/autoloader
+
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- version 2.5.2
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package