summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 14:03:55 +0200
committerRemi Collet <remi@php.net>2022-10-17 14:03:55 +0200
commitd7386f49bd13b1475d2c0f43b749078f5e2246d1 (patch)
tree862e0390cad1522eabbba2bac5fecddf0c1e64b4
parent6f13638a93850ccefce6c8ed23dd8cdc03bedef5 (diff)
update to 2.9.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json19
-rw-r--r--php-laminas-i18n-resources.spec26
2 files changed, 30 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 646c57f..a15a36a 100644
--- a/composer.json
+++ b/composer.json
@@ -17,15 +17,23 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "8.0.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.5"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "^9.5",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24"
},
"autoload": {
"classmap": [
@@ -45,7 +53,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"conflict": {
"zendframework/zend-i18n-resources": "*"
diff --git a/php-laminas-i18n-resources.spec b/php-laminas-i18n-resources.spec
index e7a40eb..31f1925 100644
--- a/php-laminas-i18n-resources.spec
+++ b/php-laminas-i18n-resources.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-i18n-resources
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 7d7062849064bb89e7cdd7193c43ef95e95fbe4b
+%global gh_commit 4e1d53bbb24136555c7d91373f7fec57af945a6a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n-resources
@@ -19,7 +19,7 @@
%global library Translator
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -31,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -40,17 +40,19 @@ BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 wi
BuildRequires: php-laminas-zendframework-bridge
%endif
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.5"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.3
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -120,7 +122,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/I18n/%{library}/autoload.php'
EOF
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -153,6 +155,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 8.0
+
* Tue Sep 14 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0 (no change)
- keep compatibility using laminas-zendframework-bridge