summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-14 09:03:10 +0200
committerRemi Collet <remi@remirepo.net>2021-09-14 09:03:10 +0200
commit6f13638a93850ccefce6c8ed23dd8cdc03bedef5 (patch)
tree2f69f5a23d8a27e810db0ffc8161b711d1cea0a9
parentfd50f79720e5d0f825d6782b4d8d9837c129ee57 (diff)
update to 2.8.0 (no change)HEADmaster
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json10
-rw-r--r--php-laminas-i18n-resources.spec14
2 files changed, 13 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 25e6618..646c57f 100644
--- a/composer.json
+++ b/composer.json
@@ -19,11 +19,9 @@
"config": {
"sort-packages": true
},
- "extra": {
- },
+ "extra": {},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -49,7 +47,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-i18n-resources": "^2.6.1"
+ "conflict": {
+ "zendframework/zend-i18n-resources": "*"
}
}
diff --git a/php-laminas-i18n-resources.spec b/php-laminas-i18n-resources.spec
index 1188962..e7a40eb 100644
--- a/php-laminas-i18n-resources.spec
+++ b/php-laminas-i18n-resources.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit fc0211052aa7576bc960b30194c87f6f60a0089c
+%global gh_commit 7d7062849064bb89e7cdd7193c43ef95e95fbe4b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n-resources
@@ -19,7 +19,7 @@
%global library Translator
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -49,8 +49,7 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -121,7 +120,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/I18n/%{library}/autoload.php'
EOF
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -154,6 +153,11 @@ exit $ret
%changelog
+* Tue Sep 14 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Fri Apr 16 2021 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0 (no change)
- raise dependency on PHP 7.3