summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-08 11:48:24 +0100
committerRemi Collet <remi@php.net>2021-12-08 11:48:24 +0100
commit3d859818a4f189342067ce05f9f248ccf18064a9 (patch)
tree1b7573674a00c735fb8df7c43f76f8f03924ca90
parent9af8228eccd513c23346943fc7d9a35537cb4e38 (diff)
update to 2.10.0 (no change)
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-file.spec16
2 files changed, 12 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index e48316a..d6452f1 100644
--- a/composer.json
+++ b/composer.json
@@ -20,8 +20,7 @@
},
"require": {
"php": "^7.3 || ~8.0.0",
- "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -58,7 +57,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-file": "^2.8.3"
+ "conflict": {
+ "zendframework/zend-file": "*"
}
}
diff --git a/php-laminas-file.spec b/php-laminas-file.spec
index 72585f9..302de29 100644
--- a/php-laminas-file.spec
+++ b/php-laminas-file.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3bfa2ea25d53d27d35736d7806f4b21bad13689c
+%global gh_commit e72846e943cfc3ac6578e4e69b259e741e6c9e05
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-file
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -78,8 +78,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^2.7.7 || ^3.1"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
@@ -190,12 +189,10 @@ exit (class_exists("\\Zend\\%{library}\\PhpClassFile") ? 0 : 1);
: upstream test suite
ret=0
-# testIgnoresMethodsNamedAfterKeywords : array order issue
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
- --filter '^((?!(testIgnoresMethodsNamedAfterKeywords)).)*$' \
--verbose || ret=1
fi
done
@@ -216,6 +213,11 @@ exit $ret
%changelog
+* Wed Dec 8 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- raise dependency on PHP 7.3