summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-15 15:23:20 +0100
committerRemi Collet <remi@remirepo.net>2021-02-15 15:23:20 +0100
commit9af8228eccd513c23346943fc7d9a35537cb4e38 (patch)
tree200f077a652d17303a14525aefcbdb8a4cd7dc2b
parentec8aa238745ad419cb0ead09691fc6199613b92c (diff)
update to 2.9.0HEADmaster
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json12
-rw-r--r--php-laminas-file.spec35
2 files changed, 25 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 16bf9c8..e48316a 100644
--- a/composer.json
+++ b/composer.json
@@ -18,14 +18,8 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.8.x-dev",
- "dev-develop": "2.9.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
@@ -37,7 +31,7 @@
"laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
"laminas/laminas-session": "^2.8",
"laminas/laminas-validator": "^2.10.1",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpunit/phpunit": "^9.3.0"
},
"suggest": {
"laminas/laminas-filter": "Laminas\\Filter component",
@@ -65,6 +59,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-file": "self.version"
+ "zendframework/zend-file": "^2.8.3"
}
}
diff --git a/php-laminas-file.spec b/php-laminas-file.spec
index 67cf98c..72585f9 100644
--- a/php-laminas-file.spec
+++ b/php-laminas-file.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-file
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit cb0bf270cc3e7a4d7dd780b573e2481a09951993
+%global gh_commit 3bfa2ea25d53d27d35736d7806f4b21bad13689c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-file
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.3
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-fileinfo
BuildRequires: php-hash
BuildRequires: php-pcre
@@ -52,7 +52,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
# "laminas/laminas-session": "^2.8",
# "laminas/laminas-validator": "^2.10.1",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+# "phpunit/phpunit": "^9.3.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7.4 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-progressbar) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-progressbar) < 3)
@@ -70,17 +70,17 @@ BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-session
BuildRequires: php-laminas-validator
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3.0
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -109,11 +109,12 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.8.3-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.8.4
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -189,10 +190,13 @@ exit (class_exists("\\Zend\\%{library}\\PhpClassFile") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+# testIgnoresMethodsNamedAfterKeywords : array order issue
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --filter '^((?!(testIgnoresMethodsNamedAfterKeywords)).)*$' \
+ --verbose || ret=1
fi
done
exit $ret
@@ -212,6 +216,11 @@ exit $ret
%changelog
+* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.8.3-1
- switch to Laminas