summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-21 11:38:23 +0100
committerRemi Collet <remi@php.net>2022-11-21 11:38:23 +0100
commit28f83b980cb271f9e57ee244e920b24f61a6f659 (patch)
tree76c6b870d30f875e5efc5223267e0a805440f282
parentc06e6f93293fb8110047596efc12382f1ef7fc8a (diff)
update to 2.12.0HEADmaster
raise dependency on PHP 8.0 raise dependency on zend-stdlib 3.15
-rw-r--r--composer.json15
-rw-r--r--php-laminas-file.spec25
2 files changed, 24 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index c53d965..e70c509 100644
--- a/composer.json
+++ b/composer.json
@@ -16,11 +16,14 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "8.0.99"
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
- "laminas/laminas-stdlib": "^2.7.7 || ^3.1"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+ "laminas/laminas-stdlib": "^2.7.7 || ^3.15.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -54,8 +57,10 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
- "test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test": "phpunit --colors=always --testsuite \"unit test\"",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "test-integration": "phpunit --colors=always --testsuite \"integration test\"",
+ "upload-coverage": "coveralls -v"
},
"conflict": {
"zendframework/zend-file": "*"
diff --git a/php-laminas-file.spec b/php-laminas-file.spec
index 27e91ed..04e46a4 100644
--- a/php-laminas-file.spec
+++ b/php-laminas-file.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8eebc51715188032161fbafeae22a618af16bdb3
+%global gh_commit 9e8ff3a6d7ccaad0865581ef672a7c48260b65d9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-file
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-fileinfo
BuildRequires: php-hash
BuildRequires: php-pcre
@@ -42,7 +42,7 @@ BuildRequires: php-spl
BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
@@ -77,13 +77,13 @@ BuildRequires: phpunit9 >= 9.5.10
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-# "laminas/laminas-stdlib": "^2.7.7 || ^3.1"
-Requires: php(language) >= 7.3
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+# "laminas/laminas-stdlib": "^2.7.7 || ^3.15.0"
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-filter": "Laminas\\Filter component",
@@ -189,12 +189,10 @@ exit (class_exists("\\Zend\\%{library}\\PhpClassFile") ? 0 : 1);
: upstream test suite
ret=0
-# testIgnoresMethodsNamedAfterKeywords : array order issue
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
- --filter '^((?!(testIgnoresMethodsNamedAfterKeywords)).)*$' \
--verbose || ret=1
fi
done
@@ -215,6 +213,11 @@ exit $ret
%changelog
+* Mon Nov 21 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on PHP 8.0
+- raise dependency on zend-stdlib 3.15
+
* Tue Feb 15 2022 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0