summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-15 09:36:33 +0100
committerRemi Collet <remi@php.net>2022-02-15 09:36:33 +0100
commitc06e6f93293fb8110047596efc12382f1ef7fc8a (patch)
treeeae1ffe908f361c4edc5cfd899e95c5718a9664a
parent2a4ae328e4cd8861c9498bcdf84c9ed1a1bdf781 (diff)
update to 2.11.0
-rw-r--r--composer.json4
-rw-r--r--php-laminas-file.spec15
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index d6452f1..c53d965 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
@@ -30,7 +30,7 @@
"laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
"laminas/laminas-session": "^2.8",
"laminas/laminas-validator": "^2.10.1",
- "phpunit/phpunit": "^9.3.0"
+ "phpunit/phpunit": "^9.5.10"
},
"suggest": {
"laminas/laminas-filter": "Laminas\\Filter component",
diff --git a/php-laminas-file.spec b/php-laminas-file.spec
index b844f85..27e91ed 100644
--- a/php-laminas-file.spec
+++ b/php-laminas-file.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-file
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e72846e943cfc3ac6578e4e69b259e741e6c9e05
+%global gh_commit 8eebc51715188032161fbafeae22a618af16bdb3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-file
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.0
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -52,7 +52,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
# "laminas/laminas-session": "^2.8",
# "laminas/laminas-validator": "^2.10.1",
-# "phpunit/phpunit": "^9.3.0"
+# "phpunit/phpunit": "^9.5.10"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7.4 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-progressbar) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-progressbar) < 3)
@@ -71,13 +71,13 @@ BuildRequires: php-laminas-session
BuildRequires: php-laminas-validator
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3.0
+BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
@@ -215,6 +215,9 @@ exit $ret
%changelog
+* Tue Feb 15 2022 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+
* Wed Dec 8 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0 (no change)
- keep compatibility using laminas-zendframework-bridge