summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-02 10:03:32 +0100
committerRemi Collet <remi@php.net>2022-12-02 10:03:32 +0100
commita5891ee4ecfadc9bdb1bbc8921aca828ac85c294 (patch)
tree596fe2bb8f28261d5c47983576c64883d71c9df3
parent74ef391f87f8862097561ad0d449c52c99fe69d7 (diff)
update to 3.7.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-eventmanager.spec17
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index b2cbfd4..69e02b4 100644
--- a/composer.json
+++ b/composer.json
@@ -34,11 +34,11 @@
"require-dev": {
"laminas/laminas-coding-standard": "~2.4.0",
"laminas/laminas-stdlib": "^3.15",
- "phpbench/phpbench": "^1.2.6",
- "phpunit/phpunit": "^9.5.25",
- "psalm/plugin-phpunit": "^0.17.0",
+ "phpbench/phpbench": "^1.2.7",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
"psr/container": "^1.1.2 || ^2.0.2",
- "vimeo/psalm": "^4.28"
+ "vimeo/psalm": "^5.0.0"
},
"suggest": {
"psr/container": "^1.1.2 || ^2.0.2, to use the lazy listeners feature",
diff --git a/php-laminas-eventmanager.spec b/php-laminas-eventmanager.spec
index c569d1b..b5733c6 100644
--- a/php-laminas-eventmanager.spec
+++ b/php-laminas-eventmanager.spec
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit 3f1afbad86cd34a431fdc069f265cfe6f8fc8308
+%global gh_commit b954c360182b9160026a8393d7b1b716dcae25d7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-eventmanager
@@ -23,7 +23,7 @@
%global library EventManager
Name: php-%{gh_project}
-Version: 3.6.0
+Version: 3.7.0
Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
@@ -48,11 +48,11 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
# "laminas/laminas-stdlib": "^3.15",
-# "phpbench/phpbench": "^1.2.6",
-# "phpunit/phpunit": "^9.5.25",
-# "psalm/plugin-phpunit": "^0.17.0",
+# "phpbench/phpbench": "^1.2.7",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
# "psr/container": "^1.1.2 || ^2.0.2",
-# "vimeo/psalm": "^4.28"
+# "vimeo/psalm": "^5.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -63,7 +63,7 @@ BuildRequires: php-psr-container2
BuildRequires: php-laminas-stdlib >= 3.6
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.25
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -199,6 +199,9 @@ exit $ret
%changelog
+* Fri Dec 2 2022 Remi Collet <remi@remirepo.net> - 3.7.0-1
+- update to 3.7.0
+
* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
- update to 3.6.0
- raise dependency on PHP 8.0