summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-12 09:44:56 +0200
committerRemi Collet <remi@php.net>2022-10-12 09:44:56 +0200
commit74ef391f87f8862097561ad0d449c52c99fe69d7 (patch)
tree9da471b37120c40d6d75be753ce9514dbf593105
parent537eb1766e46c61920d3290a25031407d9127632 (diff)
update to 3.6.0
raise dependency on PHP 8.0
-rw-r--r--composer.json23
-rw-r--r--php-laminas-eventmanager.spec39
2 files changed, 30 insertions, 32 deletions
diff --git a/composer.json b/composer.json
index da21e29..b2cbfd4 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -29,15 +29,16 @@
"extra": {
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "laminas/laminas-stdlib": "^3.15",
+ "phpbench/phpbench": "^1.2.6",
+ "phpunit/phpunit": "^9.5.25",
+ "psalm/plugin-phpunit": "^0.17.0",
"psr/container": "^1.1.2 || ^2.0.2",
- "laminas/laminas-coding-standard": "~2.2.1",
- "laminas/laminas-stdlib": "^3.6",
- "phpbench/phpbench": "^1.1",
- "phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5.5"
+ "vimeo/psalm": "^4.28"
},
"suggest": {
"psr/container": "^1.1.2 || ^2.0.2, to use the lazy listeners feature",
@@ -52,10 +53,7 @@
"psr-4": {
"LaminasTest\\EventManager\\": "test/",
"LaminasBench\\EventManager\\": "benchmarks/"
- },
- "files": [
- "test/_autoload.php"
- ]
+ }
},
"scripts": {
"benchmark": "phpbench run --revs=2 --iterations=2 --report=aggregate",
@@ -66,7 +64,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"conflict": {
"container-interop/container-interop": "<1.2",
diff --git a/php-laminas-eventmanager.spec b/php-laminas-eventmanager.spec
index 8390369..c569d1b 100644
--- a/php-laminas-eventmanager.spec
+++ b/php-laminas-eventmanager.spec
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit 41f7209428f37cab9573365e361f4078209aaafa
+%global gh_commit 3f1afbad86cd34a431fdc069f265cfe6f8fc8308
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-eventmanager
@@ -23,7 +23,7 @@
%global library EventManager
Name: php-%{gh_project}
-Version: 3.5.0
+Version: 3.6.0
Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -46,32 +46,31 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-stdlib": "^3.15",
+# "phpbench/phpbench": "^1.2.6",
+# "phpunit/phpunit": "^9.5.25",
+# "psalm/plugin-phpunit": "^0.17.0",
# "psr/container": "^1.1.2 || ^2.0.2",
-# "laminas/laminas-coding-standard": "~2.2.1",
-# "laminas/laminas-stdlib": "^3.6",
-# "phpbench/phpbench": "^1.1",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5.5"
+# "vimeo/psalm": "^4.28"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(psr/container) >= 1.1.2 with php-composer(psr/container) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:5
+# remirepo:4
%else
BuildRequires: php-psr-container2
BuildRequires: php-laminas-stdlib >= 3.6
-BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
-Requires: php(language) >= 7.4
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -167,14 +166,10 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Prophecy/PhpUnit/autoload.php',
-]);
-require_once __DIR__ . '/../test/_autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -204,6 +199,10 @@ exit $ret
%changelog
+* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+- raise dependency on PHP 8.0
+
* Thu Apr 7 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0
- raise dependency on PHP 7.4