summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-07 09:08:40 +0200
committerRemi Collet <remi@php.net>2022-04-07 09:08:40 +0200
commit537eb1766e46c61920d3290a25031407d9127632 (patch)
treef04d1a0748ff1c02c2bc38744283dc4937894fb7
parentf452abdc22e1d86712f4db833b9e019cec123ff0 (diff)
update to 3.5.0
raise dependency on PHP 7.4 switch from container-interop/container-interop to psr/container
-rw-r--r--composer.json15
-rw-r--r--php-laminas-eventmanager.spec32
2 files changed, 31 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 3f9c494..da21e29 100644
--- a/composer.json
+++ b/composer.json
@@ -18,15 +18,21 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
- "container-interop/container-interop": "^1.1",
+ "psr/container": "^1.1.2 || ^2.0.2",
"laminas/laminas-coding-standard": "~2.2.1",
"laminas/laminas-stdlib": "^3.6",
"phpbench/phpbench": "^1.1",
@@ -34,7 +40,7 @@
"phpunit/phpunit": "^9.5.5"
},
"suggest": {
- "container-interop/container-interop": "^1.1, to use the lazy listeners feature",
+ "psr/container": "^1.1.2 || ^2.0.2, to use the lazy listeners feature",
"laminas/laminas-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
},
"autoload": {
@@ -63,6 +69,7 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"conflict": {
+ "container-interop/container-interop": "<1.2",
"zendframework/zend-eventmanager": "*"
}
}
diff --git a/php-laminas-eventmanager.spec b/php-laminas-eventmanager.spec
index c4c5b5b..8390369 100644
--- a/php-laminas-eventmanager.spec
+++ b/php-laminas-eventmanager.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-eventmanager
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit a93fd278c97b2d41ebbce5ba048a24e3e6f580ba
+%global gh_commit 41f7209428f37cab9573365e361f4078209aaafa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-eventmanager
@@ -23,7 +23,7 @@
%global library EventManager
Name: php-%{gh_project}
-Version: 3.4.0
+Version: 3.5.0
Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -46,7 +46,7 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "container-interop/container-interop": "^1.1",
+# "psr/container": "^1.1.2 || ^2.0.2",
# "laminas/laminas-coding-standard": "~2.2.1",
# "laminas/laminas-stdlib": "^3.6",
# "phpbench/phpbench": "^1.1",
@@ -54,12 +54,12 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^9.5.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-composer(psr/container) >= 1.1.2 with php-composer(psr/container) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:5
%else
-BuildRequires: php-container-interop >= 1.1
+BuildRequires: php-psr-container2
BuildRequires: php-laminas-stdlib >= 3.6
BuildRequires: php-phpspec-prophecy-phpunit
%endif
@@ -70,8 +70,8 @@ BuildRequires: phpunit9 >= 9.5.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -83,9 +83,9 @@ Requires: php-laminas-zendframework-bridge
# remirepo:1
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
# From composer, "suggest": {
-# "container-interop/container-interop": "^1.1, to use the lazy listeners feature",
+# "psr/container": "^1.1.2 || ^2.0.2, to use the lazy listeners feature",
# "laminas/laminas-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
-Suggests: php-composer(container-interop/container-interop)
+Suggests: php-composer(psr/container)
Suggests: php-composer(%{gh_owner}/laminas-stdlib)
# remirepo:1
%endif
@@ -132,7 +132,10 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Interop/Container/autoload.php',
+ [
+ '%{php_home}/Psr/Container2/autoload.php',
+ '%{php_home}/Psr/Container/autoload.php',
+ ],
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
EOF
@@ -201,6 +204,11 @@ exit $ret
%changelog
+* Thu Apr 7 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+- raise dependency on PHP 7.4
+- switch from container-interop/container-interop to psr/container
+
* Wed Sep 8 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0
- keep compatibility using laminas-zendframework-bridge