summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-10 14:22:00 +0200
committerRemi Collet <remi@php.net>2022-10-10 14:22:00 +0200
commit2e2e3e0002a507790dc2c07fe1657105d067bd66 (patch)
treef5476640683f4057a7a37253ebd07b246e9c9f11
parent2c25b4d93acb44da71049dbcb6cd853252f844ca (diff)
update to 2.12.0HEADmaster
-rw-r--r--composer.json6
-rw-r--r--php-laminas-escaper.spec15
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 64513b6..75c503f 100644
--- a/composer.json
+++ b/composer.json
@@ -29,16 +29,16 @@
"extra": {
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-ctype": "*",
"ext-mbstring": "*"
},
"require-dev": {
"infection/infection": "^0.26.6",
- "laminas/laminas-coding-standard": "~2.3.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"maglnet/composer-require-checker": "^3.8.0",
"phpunit/phpunit": "^9.5.18",
- "psalm/plugin-phpunit": "^0.16.1",
+ "psalm/plugin-phpunit": "^0.17.0",
"vimeo/psalm": "^4.22.0"
},
"autoload": {
diff --git a/php-laminas-escaper.spec b/php-laminas-escaper.spec
index da94c06..030eefe 100644
--- a/php-laminas-escaper.spec
+++ b/php-laminas-escaper.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 58af67282db37d24e584a837a94ee55b9c7552be
+%global gh_commit ee7a4c37bf3d0e8c03635d5bddb5bb3184ead490
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-escaper
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -49,10 +49,10 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "infection/infection": "^0.26.6",
-# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "maglnet/composer-require-checker": "^3.8.0",
# "phpunit/phpunit": "^9.5.18",
-# "psalm/plugin-phpunit": "^0.16.1",
+# "psalm/plugin-phpunit": "^0.17.0",
# "vimeo/psalm": "^4.22.0"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5
@@ -61,7 +61,7 @@ BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-ctype": "*",
# "ext-mbstring": "*"
Requires: php(language) >= 7.4
@@ -144,7 +144,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
@@ -174,6 +174,9 @@ exit $ret
%changelog
+* Mon Oct 10 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+
* Wed Mar 9 2022 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- raise dependency on PHP 7.4