summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-09 07:43:44 +0100
committerRemi Collet <remi@php.net>2022-03-09 07:43:44 +0100
commit2c25b4d93acb44da71049dbcb6cd853252f844ca (patch)
treeba4bb3b4121c8731e72961e7b2f5c09f1fad4070
parentddbd68c990d109b78c6601f4312e4cf88cff7be1 (diff)
update to 2.10.0
raise dependency on PHP 7.4
-rw-r--r--composer.json24
-rw-r--r--php-laminas-escaper.spec34
2 files changed, 37 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 92515dc..64513b6 100644
--- a/composer.json
+++ b/composer.json
@@ -16,22 +16,30 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true,
+ "composer/package-versions-deprecated": true,
+ "infection/extension-installer": true
+ }
},
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
- },
- "suggest": {
- "ext-iconv": "*",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "ext-ctype": "*",
"ext-mbstring": "*"
},
"require-dev": {
+ "infection/infection": "^0.26.6",
"laminas/laminas-coding-standard": "~2.3.0",
- "phpunit/phpunit": "^9.3",
- "psalm/plugin-phpunit": "^0.12.2",
- "vimeo/psalm": "^3.16"
+ "maglnet/composer-require-checker": "^3.8.0",
+ "phpunit/phpunit": "^9.5.18",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.22.0"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-escaper.spec b/php-laminas-escaper.spec
index 9d885a5..da94c06 100644
--- a/php-laminas-escaper.spec
+++ b/php-laminas-escaper.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-escaper
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 891ad70986729e20ed2e86355fcf93c9dc238a5f
+%global gh_commit 58af67282db37d24e584a837a94ee55b9c7552be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-escaper
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -48,19 +48,25 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
+# "infection/infection": "^0.26.6",
# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpunit/phpunit": "^9.3",
-# "psalm/plugin-phpunit": "^0.12.2",
-# "vimeo/psalm": "^3.16"
+# "maglnet/composer-require-checker": "^3.8.0",
+# "phpunit/phpunit": "^9.5.18",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.22.0"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "ext-ctype": "*",
+# "ext-mbstring": "*"
+Requires: php(language) >= 7.4
+Requires: php-ctype
+Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -69,9 +75,7 @@ Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 wi
Requires: php-laminas-zendframework-bridge
%endif
# From phpcompatinfo report for version 2.6.1
-Requires: php-ctype
Requires: php-iconv
-Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -140,7 +144,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
@@ -170,6 +174,10 @@ exit $ret
%changelog
+* Wed Mar 9 2022 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on PHP 7.4
+
* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0 (no change)
- keep compatibility using laminas-zendframework-bridge