summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-14 10:28:17 +0100
committerRemi Collet <remi@php.net>2021-12-14 10:28:17 +0100
commit08cf0d4b15c6732d22c6e860b920a76202342189 (patch)
tree9b50f33b4d3175a07ab5c3527ceec9183257c376
parente56f50e824c6d0ffd973900245d6b8f46bdafa94 (diff)
update to 2.12.0
raise dependency on PHP 7.4
-rw-r--r--composer.json4
-rw-r--r--php-laminas-dom.spec18
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 9174032..9867aad 100644
--- a/composer.json
+++ b/composer.json
@@ -25,13 +25,13 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"ext-dom": "*",
"ext-libxml": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "^2.1.4",
- "phpunit/phpunit": "^9.4.3"
+ "phpunit/phpunit": "^9.5.10"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-dom.spec b/php-laminas-dom.spec
index d952931..3b910f2 100644
--- a/php-laminas-dom.spec
+++ b/php-laminas-dom.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b1693223bd780a6537c032a4f57f3ccf86ed9677
+%global gh_commit 5e8571a85a231807c6f8f00cab404de500d488ba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-dom
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-dom
BuildRequires: php-libxml
# remirepo:1
@@ -48,18 +48,18 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "^2.1.4",
-# "phpunit/phpunit": "^9.4.3"
+# "phpunit/phpunit": "^9.5.10"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4.3
+BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-dom": "*",
# "ext-libxml": "*"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
Requires: php-dom
Requires: php-libxml
# remirepo:1
@@ -166,6 +166,10 @@ exit $ret
%changelog
+* Tue Dec 14 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on PHP 7.4
+
* Mon Dec 13 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- keep compatibility using laminas-zendframework-bridge