summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-13 09:07:30 +0100
committerRemi Collet <remi@php.net>2021-12-13 09:07:30 +0100
commite56f50e824c6d0ffd973900245d6b8f46bdafa94 (patch)
treec232a9d2c2911120244c0598d537256d69be46fc
parent4d643688b2a1f055af27bbe3aff48dfb67853217 (diff)
update to 2.9.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-dom.spec15
2 files changed, 12 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 71bdacc..9174032 100644
--- a/composer.json
+++ b/composer.json
@@ -27,8 +27,7 @@
"require": {
"php": "^7.3 || ~8.0.0",
"ext-dom": "*",
- "ext-libxml": "*",
- "laminas/laminas-zendframework-bridge": "^1.1"
+ "ext-libxml": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "^2.1.4",
@@ -54,7 +53,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-dom": "^2.7.2"
+ "conflict": {
+ "zendframework/zend-dom": "*"
}
}
diff --git a/php-laminas-dom.spec b/php-laminas-dom.spec
index 312314e..d952931 100644
--- a/php-laminas-dom.spec
+++ b/php-laminas-dom.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7e85e8d7d2980c716944b8bb8e4a83c0a0dbe91b
+%global gh_commit b1693223bd780a6537c032a4f57f3ccf86ed9677
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-dom
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -58,9 +58,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0",
# "ext-dom": "*",
-# "ext-libxml": "*",
-# "laminas/laminas-zendframework-bridge": "^1.1"
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "ext-libxml": "*"
Requires: php(language) >= 7.3
Requires: php-dom
Requires: php-libxml
@@ -138,7 +136,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -168,6 +166,11 @@ exit $ret
%changelog
+* Mon Dec 13 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Tue Jan 12 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- raise dependency on PHP 7.3