summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-28 08:32:33 +0100
committerRemi Collet <remi@php.net>2022-02-28 08:32:33 +0100
commitcb0cf1f24fe20b394b0356e954c84d77ccba7ce5 (patch)
tree09de3c4a874d46f276e09d3924a2d06278115fe3
parent84da8ee8777395e50945bc204fb7514f1ee97019 (diff)
update to 3.4.0
raise dependency on PHP 7.4
-rw-r--r--composer.json10
-rw-r--r--php-laminas-di3.spec20
2 files changed, 19 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index e6781e7..97d37d3 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"laminas": {
@@ -26,7 +32,7 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": ">=7.4, <8.2",
"laminas/laminas-stdlib": "^3.6",
"psr/container": "^1.1.1",
"psr/log": "^1.1.4"
diff --git a/php-laminas-di3.spec b/php-laminas-di3.spec
index 8159b98..9e662b6 100644
--- a/php-laminas-di3.spec
+++ b/php-laminas-di3.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-di3
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 83330af17fc2511231e805a3586d51883a452094
+%global gh_commit fc8a5547db10908a25b03ed16452d22318b75090
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-di
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.3.0
+Version: 3.4.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component v%{major}
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-reflection
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -71,11 +71,11 @@ BuildRequires: phpunit9 >= 9.5.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": ">=7.4, <8.2",
# "laminas/laminas-stdlib": "^3.6",
# "psr/container": "^1.1.1",
# "psr/log": "^1.1.4"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -157,10 +157,8 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
]);
EOF
-sed -e 's/colors="true"/colors="true" convertDeprecationsToExceptions="true"/' \
- phpunit.xml.dist >phpunit.xml
ret=0
-for cmd in php php73 php74 php80 php81; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--verbose || ret=1
@@ -184,6 +182,10 @@ exit $ret
%changelog
+* Mon Feb 28 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- raise dependency on PHP 7.4
+
* Fri Sep 24 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- raise dependency on laminas-stdlib 3.6