summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-27 08:41:15 +0200
committerRemi Collet <remi@remirepo.net>2021-09-27 08:41:15 +0200
commit84da8ee8777395e50945bc204fb7514f1ee97019 (patch)
tree0fad296ec4991fa105d6886561316999bde957be
parentd8d302bd4cefec262c1f3e487cec593414efd42d (diff)
enable test with 8.1
-rw-r--r--php-laminas-di3.spec13
1 files changed, 7 insertions, 6 deletions
diff --git a/php-laminas-di3.spec b/php-laminas-di3.spec
index b321268..8159b98 100644
--- a/php-laminas-di3.spec
+++ b/php-laminas-di3.spec
@@ -51,10 +51,10 @@ BuildRequires: (php-composer(psr/log) >= 1.1.
# "phpstan/phpstan": "^0.12",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.5.5"
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.7 with php-composer(mikey179/vfsstream) < 2)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.10 with php-composer(mikey179/vfsstream) < 2)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:9
%else
BuildRequires: php-laminas-stdlib >= 3.6
@@ -157,9 +157,10 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
]);
EOF
+sed -e 's/colors="true"/colors="true" convertDeprecationsToExceptions="true"/' \
+ phpunit.xml.dist >phpunit.xml
ret=0
-# TODO PHP 8.1 waiting for mikey179/vfsstream 1.6.10
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--verbose || ret=1