summaryrefslogtreecommitdiffstats
path: root/php-laminas-crypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 13:47:33 +0200
committerRemi Collet <remi@php.net>2022-10-17 13:47:33 +0200
commit276d2272cd15d3bdf241febe66f6fd911d713a04 (patch)
treee1ce7fe7b96c4de44b669946173cdcb1e06c46dd /php-laminas-crypt.spec
parent313a3986aeec3c5e611c2487e64f747f5d0b69fd (diff)
update to 3.9.0 (no change)
raise dependency on PHP 8.0
Diffstat (limited to 'php-laminas-crypt.spec')
-rw-r--r--php-laminas-crypt.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/php-laminas-crypt.spec b/php-laminas-crypt.spec
index 4da244f..e2c2a34 100644
--- a/php-laminas-crypt.spec
+++ b/php-laminas-crypt.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0972bb907fd555c16e2a65309b66720acf2b8699
+%global gh_commit 56ab1b195dad5456753601ff2e8e3d3fd9392d1a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-crypt
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.8.0
+Version: 3.9.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,15 +34,15 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-mbstring
BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpunit/phpunit": "^9.5.11"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.25"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
@@ -59,19 +59,19 @@ BuildRequires: php-psr-container
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.11
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-mbstring": "*",
# "laminas/laminas-math": "^3.4",
# "laminas/laminas-servicemanager": "^3.11.2",
# "laminas/laminas-stdlib": "^3.6",
# "psr/container": "^1.1"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
Requires: php-mbstring
%if ! %{bootstrap}
# remirepo:1
@@ -184,7 +184,7 @@ FILTER="testCcmEncryptWithTagSize|testIsSupportedAndCache"
# since openssl 3.0
FILTER="$FILTER|testFactory|testSetAlgorithm|testSetCipher|testSetCipherAlgorithm|testGenerateKeysWithUnsetPrivateKey"
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -216,6 +216,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 3.9.0-1
+- update to 3.9.0 (no change)
+- raise dependency on PHP 8.0
+
* Wed Apr 13 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
- update to 3.8.0
- drop dependency on container-interop/container-interop