summaryrefslogtreecommitdiffstats
path: root/php-laminas-crypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-16 12:15:52 +0200
committerRemi Collet <remi@php.net>2022-06-16 12:15:52 +0200
commit313a3986aeec3c5e611c2487e64f747f5d0b69fd (patch)
tree3f895292fc565dce2e19f9c6202965eb06020ece /php-laminas-crypt.spec
parent12ab6585025f6acd8cb9f50dd71b8b160650c078 (diff)
update to 3.8.0
drop dependency on container-interop/container-interop add dependency on laminas/laminas-servicemanager add dependency on psr/container
Diffstat (limited to 'php-laminas-crypt.spec')
-rw-r--r--php-laminas-crypt.spec46
1 files changed, 28 insertions, 18 deletions
diff --git a/php-laminas-crypt.spec b/php-laminas-crypt.spec
index c656dac..4da244f 100644
--- a/php-laminas-crypt.spec
+++ b/php-laminas-crypt.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a0008a26b1904801ff73281f608e8de10d6deaad
+%global gh_commit 0972bb907fd555c16e2a65309b66720acf2b8699
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-crypt
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.7.0
+Version: 3.8.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -45,16 +45,17 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^9.5.11"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.11.2 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-composer(psr/container) >= 1.1 with php-composer(psr/container) < 2)
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:7
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.2
BuildRequires: php-laminas-math
+BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
+BuildRequires: php-psr-container
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
@@ -66,24 +67,26 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-mbstring": "*",
-# "container-interop/container-interop": "^1.2",
# "laminas/laminas-math": "^3.4",
-# "laminas/laminas-stdlib": "^3.6"
+# "laminas/laminas-servicemanager": "^3.11.2",
+# "laminas/laminas-stdlib": "^3.6",
+# "psr/container": "^1.1"
Requires: php(language) >= 7.4
Requires: php-mbstring
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.11.2 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-composer(psr/container) >= 1.1 with php-composer(psr/container) < 2)
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:7
%else
-Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-composer(container-interop/container-interop) >= 1.2
Requires: php-laminas-math
+Requires: php-laminas-servicemanager
Requires: php-laminas-stdlib
+Requires: php-psr-container
Requires: php-laminas-zendframework-bridge
%endif
# From composer, "suggest": {
@@ -140,8 +143,9 @@ phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Math/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
- '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/Psr/Container/autoload.php',
]);
EOF
@@ -180,7 +184,7 @@ FILTER="testCcmEncryptWithTagSize|testIsSupportedAndCache"
# since openssl 3.0
FILTER="$FILTER|testFactory|testSetAlgorithm|testSetCipher|testSetCipherAlgorithm|testGenerateKeysWithUnsetPrivateKey"
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -212,6 +216,12 @@ exit $ret
%changelog
+* Wed Apr 13 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
+- update to 3.8.0
+- drop dependency on container-interop/container-interop
+- add dependency on laminas/laminas-servicemanager
+- add dependency on psr/container
+
* Tue Apr 12 2022 Remi Collet <remi@remirepo.net> - 3.7.0-1
- update to 3.7.0
- raise dependency on PHP 7.3