summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-07 09:00:39 +0100
committerRemi Collet <remi@remirepo.net>2021-01-07 09:00:39 +0100
commitd86a5ece196150e5aadc11123ba6b5ec32b22675 (patch)
treea91a8b355991fff05ad5825f40f46650c70ca5e3
parent98f2b2801da862f21c42e27698a61d97c3c9a6c2 (diff)
update to 4.0.0HEADmaster
rename to php-laminas-code4 install in /usr/share/php/Zend/Code4 raise dependency on PHP 7.4 drop zendframework compatibility layer
-rw-r--r--composer.json22
-rw-r--r--php-laminas-code4.spec73
2 files changed, 37 insertions, 58 deletions
diff --git a/composer.json b/composer.json
index cd9dd0c..fc6a8f6 100644
--- a/composer.json
+++ b/composer.json
@@ -4,6 +4,7 @@
"license": "BSD-3-Clause",
"keywords": [
"laminas",
+ "laminasframework",
"code"
],
"homepage": "https://laminas.dev",
@@ -18,26 +19,26 @@
"config": {
"sort-packages": true
},
- "extra": {
- },
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-eventmanager": "^3.3",
- "laminas/laminas-zendframework-bridge": "^1.1"
+ "php": "^7.4 || ~8.0.0",
+ "laminas/laminas-eventmanager": "^3.3"
},
"require-dev": {
"ext-phar": "*",
"doctrine/annotations": "^1.10.4",
- "laminas/laminas-coding-standard": "^1.0.0",
+ "laminas/laminas-coding-standard": "^2.1.4",
"laminas/laminas-stdlib": "^3.3.0",
- "phpunit/phpunit": "^9.4.2"
+ "phpunit/phpunit": "^9.4.2",
+ "psalm/plugin-phpunit": "^0.14.0",
+ "vimeo/psalm": "^4.3.1"
},
"conflict": {
"phpspec/prophecy": "<1.9.0"
},
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
- "laminas/laminas-stdlib": "Laminas\\Stdlib component"
+ "laminas/laminas-stdlib": "Laminas\\Stdlib component",
+ "laminas/laminas-zendframework-bridge": "A bridge with Zend Framework"
},
"autoload": {
"psr-4": {
@@ -57,9 +58,10 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"replace": {
- "zendframework/zend-code": "^3.4.1"
+ "zendframework/zend-code": "self.version"
}
}
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
index 6eebd7d..d42dc31 100644
--- a/php-laminas-code4.spec
+++ b/php-laminas-code4.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-laminas-code
+# remirepo/Fedora spec file for php-laminas-code4
#
# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b549b70c0bb6e935d497f84f750c82653326ac77
+%global gh_commit 28a6d70ea8b8bca687d7163300e611ae33baf82a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-code
@@ -15,14 +15,15 @@
%global php_home %{_datadir}/php
%global namespace Laminas
%global library Code
+%global major 4
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_project}
-Version: 3.5.1
+Name: php-%{gh_project}%{major}
+Version: 4.0.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -42,19 +43,19 @@ BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "ext-phar": "*",
# "doctrine/annotations": "^1.10.4",
-# "laminas/laminas-coding-standard": "^1.0.0",
+# "laminas/laminas-coding-standard": "^2.1.4",
# "laminas/laminas-stdlib": "^3.3.0",
-# "phpunit/phpunit": "^9.4.2"
+# "phpunit/phpunit": "^9.4.2",
+# "psalm/plugin-phpunit": "^0.14.0",
+# "vimeo/psalm": "^4.3.1"
BuildRequires: (php-composer(doctrine/annotations) >= 1.10.4 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-# remirepo:6
+# remirepo:5
%else
BuildRequires: php-laminas-eventmanager >= 3.3
-BuildRequires: php-laminas-zendframework-bridge >= 1.1
BuildRequires: php-doctrine-annotations >= 1.10.4
BuildRequires: php-laminas-stdlib >= 3.3
%endif
@@ -64,24 +65,21 @@ BuildRequires: phpunit9 >= 9.4.2
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.4 || ~8.0.0",
# "laminas/laminas-eventmanager": "^3.3",
-# "laminas/laminas-zendframework-bridge": "^1.1"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
# "laminas/laminas-stdlib": "Laminas\\Stdlib component"
Suggests: php-composer(doctrine/annotations)
Suggests: php-autoloader(%{gh_owner}/laminas-stdlib)
-# remirepo:4
+# remirepo:3
%else
Requires: php-laminas-eventmanager >= 3.3
-Requires: php-laminas-zendframework-bridge >= 1.1
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -92,16 +90,8 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
-# remirepo:2
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.4.2
-Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
-Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
-Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
@@ -134,24 +124,11 @@ cat << 'EOF' | tee -a src/autoload.php
]);
EOF
-cat << 'EOF' | tee zf.php
-<?php
-require_once '%{php_home}/Fedora/Autoloader/autoload.php';
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
- dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
-]);
-EOF
-
%install
: Laminas library
mkdir -p %{buildroot}%{php_home}/%{namespace}/
-cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-
-: Zend equiv
-mkdir -p %{buildroot}%{php_home}/Zend/%{library}
-cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
%check
@@ -159,23 +136,17 @@ cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
done
-: check compat autoloader
-php -r '
-require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
-exit (class_exists("\\Zend\\%{library}\\NameInformation") ? 0 : 1);
-'
-
exit $ret
%else
: Test suite disabled
@@ -188,11 +159,17 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/%{library}
-%{php_home}/%{namespace}/%{library}
+%{php_home}/%{namespace}/%{library}%{major}
%changelog
+* Thu Jan 7 2021 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- rename to php-laminas-code4
+- install in /usr/share/php/Zend/Code4
+- raise dependency on PHP 7.4
+- drop zendframework compatibility layer
+
* Tue Dec 1 2020 Remi Collet <remi@remirepo.net> - 3.5.1-1
- update to 3.5.1 (no change)