summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-07 08:47:41 +0100
committerRemi Collet <remi@remirepo.net>2021-01-07 08:47:41 +0100
commit98f2b2801da862f21c42e27698a61d97c3c9a6c2 (patch)
tree656de79cf2cefd131fb1e3b4920343ede7f308d9
duplicate v3
-rw-r--r--.gitignore9
-rw-r--r--Makefile3
-rw-r--r--composer.json65
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-code4.spec271
5 files changed, 376 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cd9dd0c
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,65 @@
+{
+ "name": "laminas/laminas-code",
+ "description": "Extensions to the PHP Reflection API, static code scanning, and code generation",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "laminas",
+ "code"
+ ],
+ "homepage": "https://laminas.dev",
+ "support": {
+ "docs": "https://docs.laminas.dev/laminas-code/",
+ "issues": "https://github.com/laminas/laminas-code/issues",
+ "source": "https://github.com/laminas/laminas-code",
+ "rss": "https://github.com/laminas/laminas-code/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ },
+ "require": {
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-eventmanager": "^3.3",
+ "laminas/laminas-zendframework-bridge": "^1.1"
+ },
+ "require-dev": {
+ "ext-phar": "*",
+ "doctrine/annotations": "^1.10.4",
+ "laminas/laminas-coding-standard": "^1.0.0",
+ "laminas/laminas-stdlib": "^3.3.0",
+ "phpunit/phpunit": "^9.4.2"
+ },
+ "conflict": {
+ "phpspec/prophecy": "<1.9.0"
+ },
+ "suggest": {
+ "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
+ "laminas/laminas-stdlib": "Laminas\\Stdlib component"
+ },
+ "autoload": {
+ "psr-4": {
+ "Laminas\\Code\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "LaminasTest\\Code\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-code": "^3.4.1"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
new file mode 100644
index 0000000..6eebd7d
--- /dev/null
+++ b/php-laminas-code4.spec
@@ -0,0 +1,271 @@
+# remirepo/Fedora spec file for php-laminas-code
+#
+# Copyright (c) 2015-2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit b549b70c0bb6e935d497f84f750c82653326ac77
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner laminas
+%global gh_project laminas-code
+%global zf_name zend-code
+%global php_home %{_datadir}/php
+%global namespace Laminas
+%global library Code
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_project}
+Version: 3.5.1
+Release: 1%{?dist}
+Summary: Laminas Framework %{library} component
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+BuildRequires: php-tokenizer
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "ext-phar": "*",
+# "doctrine/annotations": "^1.10.4",
+# "laminas/laminas-coding-standard": "^1.0.0",
+# "laminas/laminas-stdlib": "^3.3.0",
+# "phpunit/phpunit": "^9.4.2"
+BuildRequires: (php-composer(doctrine/annotations) >= 1.10.4 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+# remirepo:6
+%else
+BuildRequires: php-laminas-eventmanager >= 3.3
+BuildRequires: php-laminas-zendframework-bridge >= 1.1
+BuildRequires: php-doctrine-annotations >= 1.10.4
+BuildRequires: php-laminas-stdlib >= 3.3
+%endif
+BuildRequires: phpunit9 >= 9.4.2
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-eventmanager": "^3.3",
+# "laminas/laminas-zendframework-bridge": "^1.1"
+Requires: php(language) >= 7.3
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
+# "laminas/laminas-stdlib": "Laminas\\Stdlib component"
+Suggests: php-composer(doctrine/annotations)
+Suggests: php-autoloader(%{gh_owner}/laminas-stdlib)
+# remirepo:4
+%else
+Requires: php-laminas-eventmanager >= 3.3
+Requires: php-laminas-zendframework-bridge >= 1.1
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+%endif
+# From phpcompatinfo report for version 3.4.1
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+Requires: php-tokenizer
+
+# remirepo:2
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.4.2
+Provides: php-zendframework-%{zf_name} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
+
+
+%description
+%{gh_project} provides facilities to generate arbitrary code using
+an object-oriented interface, both to create new code as well as to update
+existing code. While the current implementation is limited to generating
+PHP code, you can easily extend the base class in order to provide code
+generation for other tasks: JavaScript, configuration files, apache vhosts,
+etc.
+
+Documentation: https://docs.laminas.dev/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/EventManager/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Doctrine/Common/Annotations/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
+]);
+EOF
+
+
+%install
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\NameInformation") ? 0 : 1);
+'
+
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
+
+
+%changelog
+* Tue Dec 1 2020 Remi Collet <remi@remirepo.net> - 3.5.1-1
+- update to 3.5.1 (no change)
+
+* Thu Nov 12 2020 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-eventmanager 3.3
+- raise dependency on laminas-zendframework-bridge 1..1
+- switch to phpunit9
+
+* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.4.1-2
+- cleanup
+
+* Tue Jan 7 2020 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- switch to Laminas
+
+* Wed Dec 11 2019 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- update to 3.4.1
+
+* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- drop patch merged upstream
+- use phpunit8
+
+* Mon Sep 2 2019 Remi Collet <remi@remirepo.net> - 3.3.2-2
+- update to 3.3.2
+- use phpunit7
+- use range dependencies
+- add patch for PHP 7.4 from
+ https://github.com/zendframework/zend-code/pull/172
+
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 3.3.1-1
+- update to 3.3.1
+
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 3.3.0-2
+- switch from zend-loader to fedora/autoloader
+
+* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- Update to 3.3.0
+
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- Update to 3.2.0
+- raise dependency on PHP 7.1
+- switch to phpunit6
+
+* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
+- update to 3.1.0
+- raise dependency on PHP 5.6
+
+* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
+- update to 3.0.4
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.3-2
+- add patch for ocramius/proxy-manager
+ https://github.com/zendframework/zend-code/pull/80
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
+- update to 3.0.0 for ZendFramework 3
+
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 2.6.3-1
+- update to 2.6.3
+
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.2-1
+- update to 2.6.2
+- dependency on doctrine/annotations instrad of doctrine/common
+- raise dependency on zend-stdlib ~2.7
+- raise dependency on zend-eventmanager ~2.6
+
+* Thu Nov 19 2015 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- update to 2.5.3
+- run test suite with both PHP 5 and 7 when available
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package
+- open https://github.com/zendframework/zend-code/pull/5
+ avoid using 'vendor' path