summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-06 12:42:40 +0100
committerRemi Collet <remi@php.net>2023-03-06 12:42:40 +0100
commit14e309466ed5e648e6bded517571153da3e86be2 (patch)
treeb11e0af251804504a435f2b2b9478fcb63804896
parent4daf595f4785b91b91906f78819889099c29c832 (diff)
update to 4.9.0
raise build dependency on doctrine/annotations 2 switch to phpunit10
-rw-r--r--composer.json8
-rw-r--r--php-laminas-code4.spec29
2 files changed, 21 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 5dbf259..4a551f8 100644
--- a/composer.json
+++ b/composer.json
@@ -13,12 +13,12 @@
},
"require-dev": {
"ext-phar": "*",
- "doctrine/annotations": "^1.13.3",
+ "doctrine/annotations": "^2.0.0",
"laminas/laminas-coding-standard": "^2.3.0",
"laminas/laminas-stdlib": "^3.6.1",
- "phpunit/phpunit": "^9.5.26",
- "psalm/plugin-phpunit": "^0.18.0",
- "vimeo/psalm": "^5.1.0"
+ "phpunit/phpunit": "^10.0.9",
+ "psalm/plugin-phpunit": "^0.18.4",
+ "vimeo/psalm": "^5.7.1"
},
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
index d805833..03a58ff 100644
--- a/php-laminas-code4.spec
+++ b/php-laminas-code4.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-code4
#
-# Copyright (c) 2015-2022 Remi Collet
+# Copyright (c) 2015-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit dd19fe8e07cc3f374308565667eecd4958c22106
+%global gh_commit c1706ecde17f87ae8bab169c4b88006c9253d3a5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-code
@@ -23,11 +23,11 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 4.8.0
+Version: 4.9.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.1
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -44,12 +44,12 @@ BuildRequires: php-tokenizer
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer, "require-dev": {
# "ext-phar": "*",
-# "doctrine/annotations": "^1.13.3",
+# "doctrine/annotations": "^2.0.0",
# "laminas/laminas-coding-standard": "^2.3.0",
# "laminas/laminas-stdlib": "^3.6.1",
-# "phpunit/phpunit": "^9.5.26",
-# "psalm/plugin-phpunit": "^0.18.0",
-# "vimeo/psalm": "^5.1.0"
+# "phpunit/phpunit": "^10.0.9",
+# "psalm/plugin-phpunit": "^0.18.4",
+# "vimeo/psalm": "^5.7.1"
BuildRequires: (php-composer(doctrine/annotations) >= 1.13.3 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
# remirepo:4
@@ -64,7 +64,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "php": "~8.1.0 || ~8.2.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.1
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -110,7 +110,7 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Doctrine/Common/Annotations/autoload.php',
+ '%{php_home}/Doctrine/Common/Annotations2/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
EOF
@@ -134,7 +134,7 @@ EOF
ret=0
for cmd in php php81 php82; do
if which $cmd; then
- $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ $cmd %{_bindir}/phpunit10 || ret=1
fi
done
@@ -154,6 +154,11 @@ exit $ret
%changelog
+* Mon Mar 6 2023 Remi Collet <remi@remirepo.net> - 4.9.0-1
+- update to 4.9.0
+- raise build dependency on doctrine/annotations 2
+- switch to phpunit10
+
* Thu Dec 8 2022 Remi Collet <remi@remirepo.net> - 4.8.0-1
- update to 4.8.0
- raise dependency on PHP 8.1