summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-08 11:25:06 +0100
committerRemi Collet <remi@php.net>2022-12-08 11:25:06 +0100
commit4daf595f4785b91b91906f78819889099c29c832 (patch)
tree9abfd59cf940dba66277d267128eec3c30b646f0
parentd540260e304d08fbbb5afd9950dc5534a294d2f0 (diff)
update to 4.8.0
raise dependency on PHP 8.1
-rw-r--r--composer.json17
-rw-r--r--php-laminas-code4.spec26
2 files changed, 21 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 983878e..5dbf259 100644
--- a/composer.json
+++ b/composer.json
@@ -9,16 +9,16 @@
"homepage": "https://laminas.dev",
"license": "BSD-3-Clause",
"require": {
- "php": ">=7.4, <8.2"
+ "php": "~8.1.0 || ~8.2.0"
},
"require-dev": {
"ext-phar": "*",
- "doctrine/annotations": "^1.13.2",
+ "doctrine/annotations": "^1.13.3",
"laminas/laminas-coding-standard": "^2.3.0",
"laminas/laminas-stdlib": "^3.6.1",
- "phpunit/phpunit": "^9.5.10",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.13.1"
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^5.1.0"
},
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
@@ -29,17 +29,14 @@
"dealerdirect/phpcodesniffer-composer-installer": true
},
"platform": {
- "php": "7.4.99"
+ "php": "8.1.99"
},
"sort-packages": true
},
"autoload": {
"psr-4": {
"Laminas\\Code\\": "src/"
- },
- "files": [
- "polyfill/ReflectionEnumPolyfill.php"
- ]
+ }
},
"autoload-dev": {
"psr-4": {
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
index 463b535..d805833 100644
--- a/php-laminas-code4.spec
+++ b/php-laminas-code4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 91aabc066d5620428120800c0eafc0411e441a62
+%global gh_commit dd19fe8e07cc3f374308565667eecd4958c22106
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-code
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 4.7.1
+Version: 4.8.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -44,26 +44,26 @@ BuildRequires: php-tokenizer
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer, "require-dev": {
# "ext-phar": "*",
-# "doctrine/annotations": "^1.13.2",
+# "doctrine/annotations": "^1.13.3",
# "laminas/laminas-coding-standard": "^2.3.0",
# "laminas/laminas-stdlib": "^3.6.1",
-# "phpunit/phpunit": "^9.5.10",
-# "psalm/plugin-phpunit": "^0.16.1",
-# "vimeo/psalm": "^4.13.1"
-BuildRequires: (php-composer(doctrine/annotations) >= 1.13.2 with php-composer(doctrine/annotations) < 2)
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^5.1.0"
+BuildRequires: (php-composer(doctrine/annotations) >= 1.13.3 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
# remirepo:4
%else
BuildRequires: php-doctrine-annotations >= 1.13.2
BuildRequires: php-laminas-stdlib >= 3.6.1
%endif
-BuildRequires: phpunit9 >= 9.5.10
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "php": ">=7.4, <8.2"
+# "php": "php": "~8.1.0 || ~8.2.0"
Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
@@ -112,7 +112,6 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
- __DIR__ . '/polyfill/ReflectionEnumPolyfill.php',
]);
EOF
@@ -121,7 +120,6 @@ EOF
: Laminas library
mkdir -p %{buildroot}%{php_home}/%{namespace}/
cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
-cp -pr polyfill %{buildroot}%{php_home}/%{namespace}/%{library}%{major}/polyfill
%check
@@ -134,7 +132,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
EOF
ret=0
-for cmd in php php80 php81 php82; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -156,6 +154,10 @@ exit $ret
%changelog
+* Thu Dec 8 2022 Remi Collet <remi@remirepo.net> - 4.8.0-1
+- update to 4.8.0
+- raise dependency on PHP 8.1
+
* Mon Nov 21 2022 Remi Collet <remi@remirepo.net> - 4.7.1-1
- update to 4.7.1