summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-04 07:55:07 +0200
committerRemi Collet <remi@remirepo.net>2021-06-04 07:55:07 +0200
commitc6f280bca62f88793451b9aeee6b9c9fc2048db9 (patch)
tree240ef878d11d8aaee0fe73b0968f96830d1fc698
parent87bbfd8829e4e8b34e9b04e9a48e5d8cc4f1e2f4 (diff)
update to 2.11.2
update laminas-cache-storage-adapter-redis to 1.2.0
-rw-r--r--composer-redis.json13
-rw-r--r--php-laminas-cache.spec14
2 files changed, 18 insertions, 9 deletions
diff --git a/composer-redis.json b/composer-redis.json
index 42716d9..24abb7b 100644
--- a/composer-redis.json
+++ b/composer-redis.json
@@ -17,16 +17,19 @@
"laminas/laminas-cache-storage-implementation": "1.0"
},
"require-dev": {
+ "ext-posix": "*",
"ext-redis": "*",
+ "composer-runtime-api": "^2",
"laminas/laminas-cache": "^2.10",
"laminas/laminas-cache-storage-adapter-test": "^1.1",
"laminas/laminas-coding-standard": "^2.1",
- "laminas/laminas-serializer": "^2.10"
+ "laminas/laminas-serializer": "^2.10",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.7"
},
"config": {
"sort-packages": true
},
- "extra": {},
"autoload": {
"psr-4": {
"Laminas\\Cache\\Storage\\Adapter\\": "src/"
@@ -35,14 +38,16 @@
"autoload-dev": {
"psr-4": {
"LaminasTest\\Cache\\Storage\\Adapter\\": "test/unit",
- "LaminasTest\\Cache\\Psr\\": "test/integration/Psr"
+ "LaminasTest\\Cache\\Psr\\": "test/integration/Psr",
+ "LaminasTest\\Cache\\Storage\\Adapter\\Laminas\\": "test/integration/Laminas"
}
},
"scripts": {
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"support": {
"issues": "https://github.com/laminas/laminas-cache-storage-adapter-redis/issues",
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index e8636dd..1cb61cc 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -11,7 +11,7 @@
# When buid without laminas-session
%global bootstrap 0
-%global gh_commit f888588c3a40916e505658c9e8b8922166b70ec6
+%global gh_commit f825aecc67f40e8bc499500373e5de700b95d00b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-cache
@@ -65,8 +65,8 @@
%global gh_mongodb_version 1.0.1
%global gh_mongodb_short %(c=%{gh_mongodb_commit}; echo ${c:0:7})
# Redis adapter
-%global gh_redis_commit f871faafa8706f662ff10bc6ac63271b463af2ff
-%global gh_redis_version 1.1.0
+%global gh_redis_commit de8a63d4a0ef1ccead401eb7fb6d75b57fa3f9ee
+%global gh_redis_version 1.2.0
%global gh_redis_short %(c=%{gh_redis_commit}; echo ${c:0:7})
# Session adapter
%global gh_session_commit 74a275056cfca2300eb9a67cd1d917f7066b4113
@@ -87,8 +87,8 @@
Name: php-%{gh_project}
-Version: 2.11.1
-Release: 2%{?dist}
+Version: 2.11.2
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -388,6 +388,10 @@ exit $ret
%changelog
+* Fri Jun 4 2021 Remi Collet <remi@remirepo.net> - 2.11.2-1
+- update to 2.11.2
+- update laminas-cache-storage-adapter-redis to 1.2.0
+
* Fri May 7 2021 Remi Collet <remi@remirepo.net> - 2.11.1-1
- update laminas-cache-storage-adapter-ext-mongodb to 1.1.0