summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-28 08:54:52 +0200
committerRemi Collet <remi@remirepo.net>2020-05-28 08:54:52 +0200
commitab3dc1bf3fbc29fe13ec2ff80d6986e0201bdcc9 (patch)
treeb74f5f3f54763084887498bf6100faa8cbfa7f62
parent413602a0a4c3bebde69b9fa196698b02456f4de8 (diff)
v5.2.10
-rw-r--r--composer.json4
l---------makesrc.sh1
-rwxr-xr-xphp-justinrainbow-json-schema5-makesrc.sh4
-rw-r--r--php-justinrainbow-json-schema5.spec12
4 files changed, 11 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 884a697..fcacd40 100644
--- a/composer.json
+++ b/composer.json
@@ -31,7 +31,7 @@
},
"require-dev": {
"friendsofphp/php-cs-fixer": "~2.2.20||~2.15.1",
- "json-schema/JSON-Schema-Test-Suite": "1.2.0",
+ "json-schema/json-schema-test-suite": "1.2.0",
"phpunit/phpunit": "^4.8.35"
},
"extra": {
@@ -53,7 +53,7 @@
{
"type": "package",
"package": {
- "name": "json-schema/JSON-Schema-Test-Suite",
+ "name": "json-schema/json-schema-test-suite",
"version": "1.2.0",
"source": {
"type": "git",
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..434af7b
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-justinrainbow-json-schema5-makesrc.sh \ No newline at end of file
diff --git a/php-justinrainbow-json-schema5-makesrc.sh b/php-justinrainbow-json-schema5-makesrc.sh
index e9f0fbc..dfd5c2a 100755
--- a/php-justinrainbow-json-schema5-makesrc.sh
+++ b/php-justinrainbow-json-schema5-makesrc.sh
@@ -3,9 +3,7 @@
NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
-MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
-VERSION=$MAJOR.$MINOR
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
diff --git a/php-justinrainbow-json-schema5.spec b/php-justinrainbow-json-schema5.spec
index d10f410..c67d250 100644
--- a/php-justinrainbow-json-schema5.spec
+++ b/php-justinrainbow-json-schema5.spec
@@ -6,14 +6,13 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 44c6787311242a979fa15c704327c20e7221a0e4
+%global gh_commit 2ba9c8c862ecd5510ed16c6340aa9f6eadb4f31b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner justinrainbow
%global gh_project json-schema
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
%global major 5
-%global minor 2.9
# Some sample files, only used for tests
@@ -28,7 +27,7 @@
%global eolv2 0
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: %{major}.%{minor}
+Version: 5.2.10
Release: 1%{?dist}
Summary: A library to validate a json schema
License: MIT
@@ -55,7 +54,7 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "json-schema/JSON-Schema-Test-Suite": "1.2.0",
+# "json-schema/json-schema-test-suite": "1.2.0",
# "friendsofphp/php-cs-fixer": "^2.1",
# "phpunit/phpunit": "^4.8.35"
BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
@@ -157,7 +156,7 @@ php bin/validate-json-test \
: Upstream test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit -d memory_limit=1G --verbose || ret=1
fi
@@ -180,6 +179,9 @@ exit $ret
%changelog
+* Thu May 28 2020 Remi Collet <remi@remirepo.net> - 5.2.10-1
+- update to 5.2.10
+
* Thu Sep 26 2019 Remi Collet <remi@remirepo.net> - 5.2.9-1
- update to 5.2.9