summaryrefslogtreecommitdiffstats
path: root/php-justinrainbow-json-schema5-makesrc.sh
diff options
context:
space:
mode:
Diffstat (limited to 'php-justinrainbow-json-schema5-makesrc.sh')
-rwxr-xr-xphp-justinrainbow-json-schema5-makesrc.sh4
1 files changed, 1 insertions, 3 deletions
diff --git a/php-justinrainbow-json-schema5-makesrc.sh b/php-justinrainbow-json-schema5-makesrc.sh
index e9f0fbc..dfd5c2a 100755
--- a/php-justinrainbow-json-schema5-makesrc.sh
+++ b/php-justinrainbow-json-schema5-makesrc.sh
@@ -3,9 +3,7 @@
NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
-MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
-VERSION=$MAJOR.$MINOR
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}