summaryrefslogtreecommitdiffstats
path: root/php-justinrainbow-json-schema4-makesrc.sh
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-23 06:47:13 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-23 06:47:13 +0100
commit20e1a452def4607bee49d2b803073fe609e89989 (patch)
tree7b3972b73ec81f1233dbc094a2d3dce1b37c3f37 /php-justinrainbow-json-schema4-makesrc.sh
parent3f1ef106ecc8f365f3c5dbe533d4cdc1c50adc33 (diff)
php-justinrainbow-json-schema4: 4.1.0
Diffstat (limited to 'php-justinrainbow-json-schema4-makesrc.sh')
-rwxr-xr-xphp-justinrainbow-json-schema4-makesrc.sh4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-justinrainbow-json-schema4-makesrc.sh b/php-justinrainbow-json-schema4-makesrc.sh
index dfd5c2a..e9f0fbc 100755
--- a/php-justinrainbow-json-schema4-makesrc.sh
+++ b/php-justinrainbow-json-schema4-makesrc.sh
@@ -3,7 +3,9 @@
NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
+MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
+VERSION=$MAJOR.$MINOR
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}