summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-23 06:47:13 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-23 06:47:13 +0100
commit20e1a452def4607bee49d2b803073fe609e89989 (patch)
tree7b3972b73ec81f1233dbc094a2d3dce1b37c3f37
parent3f1ef106ecc8f365f3c5dbe533d4cdc1c50adc33 (diff)
php-justinrainbow-json-schema4: 4.1.0
-rw-r--r--composer.json1
-rwxr-xr-xphp-justinrainbow-json-schema4-makesrc.sh4
-rw-r--r--php-justinrainbow-json-schema4-pr342.patch24
-rw-r--r--php-justinrainbow-json-schema4.spec11
4 files changed, 10 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index 738c09d..b0ad6b5 100644
--- a/composer.json
+++ b/composer.json
@@ -57,6 +57,7 @@
},
"scripts": {
"test" : "vendor/bin/phpunit",
+ "testOnly" : "vendor/bin/phpunit --colors --filter",
"coverage" : "vendor/bin/phpunit --coverage-text"
}
}
diff --git a/php-justinrainbow-json-schema4-makesrc.sh b/php-justinrainbow-json-schema4-makesrc.sh
index dfd5c2a..e9f0fbc 100755
--- a/php-justinrainbow-json-schema4-makesrc.sh
+++ b/php-justinrainbow-json-schema4-makesrc.sh
@@ -3,7 +3,9 @@
NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
+MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
+VERSION=$MAJOR.$MINOR
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
diff --git a/php-justinrainbow-json-schema4-pr342.patch b/php-justinrainbow-json-schema4-pr342.patch
deleted file mode 100644
index db15d33..0000000
--- a/php-justinrainbow-json-schema4-pr342.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From b0a382eaee1e5084e2785d516a31897f90c2b219 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 12 Dec 2016 10:17:02 +0100
-Subject: [PATCH] fix #341 validate-json command
-
----
- bin/validate-json | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/bin/validate-json b/bin/validate-json
-index 8184e7b..e9c1809 100755
---- a/bin/validate-json
-+++ b/bin/validate-json
-@@ -207,8 +207,8 @@ try {
- echo $e->getMessage() . "\n";
- exit(2);
- }
--$refResolver = new JsonSchema\RefResolver($retriever, $resolver);
--$schema = $refResolver->resolve($urlSchema);
-+$refResolver = new JsonSchema\SchemaStorage($retriever, $resolver);
-+$schema = $refResolver->resolveRef($urlSchema);
-
- if (isset($arOptions['--dump-schema'])) {
- $options = defined('JSON_PRETTY_PRINT') ? JSON_PRETTY_PRINT : 0;
diff --git a/php-justinrainbow-json-schema4.spec b/php-justinrainbow-json-schema4.spec
index d8ec83e..77197b6 100644
--- a/php-justinrainbow-json-schema4.spec
+++ b/php-justinrainbow-json-schema4.spec
@@ -6,14 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 10d1f6977f6be5f177dded8f585a11debdc27591
+%global gh_commit d39c56a46b3ebe1f3696479966cd2b9f50aaa24f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner justinrainbow
%global gh_project json-schema
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
%global major 4
-%global minor 0.1
+%global minor 1.0
# Some sample files, only used for tests
@@ -49,8 +49,6 @@ Source3: %{name}-makesrc.sh
# Autoloader
Patch0: %{name}-rpm.patch
-# https://github.com/justinrainbow/json-schema/issues/341
-Patch1: %{name}-pr342.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -122,7 +120,6 @@ Autoloader: %{php_home}/JsonSchema%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit} -a 1
-%patch1 -p1 -b .342
%patch0 -p0 -b .rpm
cp %{SOURCE2} src/JsonSchema/autoload.php
@@ -218,6 +215,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Dec 23 2016 Remi Collet <remi@fedoraproject.org> - 4.1.0-1
+- update to 4.1.0
+- dro ppatch merged upstream
+
* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 4.0.1-1
- rename to php-justinrainbow-json-schema4
- update to 4.0.1