summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-JsonSchema.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index af5a607..7d6efb5 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -93,7 +93,9 @@ cat > autoload.php <<'AUTOLOAD'
<?php
spl_autoload_register(function ($class) {
$src = str_replace('\\', '/', $class).'.php';
- @include $src;
+ if ($path = stream_resolve_include_path($src)) {
+ require_once $path;
+ }
});
AUTOLOAD
@@ -122,6 +124,9 @@ rm -rf tests/JsonSchema/Tests/Drafts
* Mon Jun 15 2015 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
- update to 1.4.2
+* Mon Apr 13 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-2
+- fix tests autoloader (FTBFS detected by Koschei)
+
* Fri Mar 27 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
- Update to 1.4.1