summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-15 10:51:21 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-15 10:51:21 +0200
commit689cd7f14c307686599092eb061ad7a1c592d150 (patch)
tree756e132024f920a16ce576a96cfadddb7d06618e
parente2b9ce080782c777002d061f1064c85b6eddfd86 (diff)
php-JsonSchema: rawhide changes
-rw-r--r--php-JsonSchema.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index af5a607..7d6efb5 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -93,7 +93,9 @@ cat > autoload.php <<'AUTOLOAD'
<?php
spl_autoload_register(function ($class) {
$src = str_replace('\\', '/', $class).'.php';
- @include $src;
+ if ($path = stream_resolve_include_path($src)) {
+ require_once $path;
+ }
});
AUTOLOAD
@@ -122,6 +124,9 @@ rm -rf tests/JsonSchema/Tests/Drafts
* Mon Jun 15 2015 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
- update to 1.4.2
+* Mon Apr 13 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-2
+- fix tests autoloader (FTBFS detected by Koschei)
+
* Fri Mar 27 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
- Update to 1.4.1