summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-15 16:25:58 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-15 16:25:58 +0100
commit74953bcc6760c0e821889b8a1f11818e4cc055b8 (patch)
tree047cc4d4f416b5fcd50fe1151ea0f89f1478aa07
parent0586b2be5a02556bc77311b08967a77520b4cd97 (diff)
php-horde-Horde-Routes: add patch for http://bugs.horde.org/ticket/11894
-rw-r--r--Horde_Routes-php54.patch11
-rw-r--r--php-horde-Horde-Routes.spec24
2 files changed, 28 insertions, 7 deletions
diff --git a/Horde_Routes-php54.patch b/Horde_Routes-php54.patch
new file mode 100644
index 0000000..8b28a1c
--- /dev/null
+++ b/Horde_Routes-php54.patch
@@ -0,0 +1,11 @@
+--- lib/Horde/Routes/Mapper.php~ 2012-12-15 16:01:14.332176067 +0100
++++ lib/Horde/Routes/Mapper.php 2012-12-15 16:01:20.330194840 +0100
+@@ -591,7 +591,7 @@
+ // If the URL didn't depend on the SCRIPT_NAME, we'll cache it
+ // keyed by just the $kargs; otherwise we need to cache it with
+ // both SCRIPT_NAME and $kargs:
+- $cacheKey = $kargs;
++ $cacheKey = serialize($kargs);
+ if (!empty($environ['SCRIPT_NAME'])) {
+ $cacheKeyScriptName = sprintf('%s:%s', $environ['SCRIPT_NAME'], $cacheKey);
+ } else {
diff --git a/php-horde-Horde-Routes.spec b/php-horde-Horde-Routes.spec
index 8d062d9..5c81322 100644
--- a/php-horde-Horde-Routes.spec
+++ b/php-horde-Horde-Routes.spec
@@ -5,14 +5,18 @@
Name: php-horde-Horde-Routes
Version: 2.0.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Horde Routes URL mapping system
Group: Development/Libraries
-License: BSD-2-Clause
+License: BSD
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# http://bugs.horde.org/ticket/11894
+# Horde_Routes: Array to string conversion
+Patch0: %{pear_name}-php54.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -23,10 +27,12 @@ BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php-pear(PEAR) >= 1.7.0
-Requires: php(language) >= 5.3.0
+Requires: php-common >= 5.3.0
Requires: php-pcre
Requires: php-spl
# note xml extension provided by php-common and not php-xml
+# but this will change in a near futur
+Requires: php-xml
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
@@ -46,7 +52,9 @@ It is a port of a Python library, Routes, by Ben Bangert
%setup -q -c
cd %{pear_name}-%{version}
-cp ../package.xml %{name}.xml
+%patch0 -p0 -b .php54
+sed -e '/Mapper.php/s/md5sum.*name/name/' \
+ ../package.xml >%{name}.xml
%build
@@ -68,11 +76,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-# PHP 5.4 issue (Array to string conversion)
phpunit\
-d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
-d date.timezone=UTC \
- . || exit 0
+ .
%post
@@ -95,5 +102,8 @@ fi
%changelog
-* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
+* Sat Dec 15 2012 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
+- add patch for http://bugs.horde.org/ticket/11894
+
+* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
- Initial package