summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-19 23:29:40 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-19 23:29:40 +0100
commit0586b2be5a02556bc77311b08967a77520b4cd97 (patch)
tree3e30bdcc07430d5cce53a54edc3c90c47bd0b7a9
php-horde-Horde-Routes: new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Routes.spec99
2 files changed, 103 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Routes.spec b/php-horde-Horde-Routes.spec
new file mode 100644
index 0000000..8d062d9
--- /dev/null
+++ b/php-horde-Horde-Routes.spec
@@ -0,0 +1,99 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Routes
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Routes
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: Horde Routes URL mapping system
+
+Group: Development/Libraries
+License: BSD-2-Clause
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php(language) >= 5.3.0
+Requires: php-pcre
+Requires: php-spl
+# note xml extension provided by php-common and not php-xml
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Classes for mapping URLs into the controllers and actions of an MVC system.
+It is a port of a Python library, Routes, by Ben Bangert
+(http://routes.groovie.org).
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+# PHP 5.4 issue (Array to string conversion)
+phpunit\
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ . || exit 0
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Routes
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
+- Initial package