summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-02 06:18:49 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-02 06:18:49 +0200
commit73a647c1bfba93c3ce07a429bf15826a50f92ea8 (patch)
treee34c404d17ed73d1abcc7b6e6fa2bdde11733cc3
parentc090907d50366110b23b3e0c0507a4dbd1590e51 (diff)
php-horde-Horde-Imap-Client: skip tests when phpunit is too old
-rw-r--r--php-horde-Horde-Imap-Client.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/php-horde-Horde-Imap-Client.spec b/php-horde-Horde-Imap-Client.spec
index 3479713..e4a74a8 100644
--- a/php-horde-Horde-Imap-Client.spec
+++ b/php-horde-Horde-Imap-Client.spec
@@ -139,7 +139,11 @@ done | tee ../%{pear_name}.lang
export LANG=fr_FR.utf8
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit --verbose .
+if %{_bindir}/phpunit --atleast-version 4.8; then
+ %{_bindir}/phpunit --verbose .
+else
+ : PHPUnit is too old for this package
+fi
if which php70; then
php70 %{_bindir}/phpunit --verbose .