summaryrefslogtreecommitdiffstats
path: root/php-guzzlehttp-guzzle6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-26 09:53:30 +0200
committerRemi Collet <remi@remirepo.net>2017-06-26 09:53:30 +0200
commitedcbdd5185732720098144de0f9d7650096face4 (patch)
treeeaaa5cace62b996085a835e551e169aba159b70a /php-guzzlehttp-guzzle6.spec
parent2dacf9e15758be10401be825556bef0d63f23a7b (diff)
v6.3.0 (backported from Fedora)
Diffstat (limited to 'php-guzzlehttp-guzzle6.spec')
-rw-r--r--php-guzzlehttp-guzzle6.spec28
1 files changed, 13 insertions, 15 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index 2b437ab..e4c82c1 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.2.3
-%global github_commit 8d6c6cc55186db87b7dc5009827429ba4e9dc006
+%global github_version 6.3.0
+%global github_commit f4db5a78a5ea468d4831de7f0bf9d9415e348699
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -51,11 +51,6 @@ URL: http://guzzlephp.org
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Proxy should not end with /
-# https://github.com/guzzle/guzzle/pull/1792
-# https://github.com/guzzle/guzzle/pull/1792.patch
-Patch0: %{name}-upstream-pull-1792.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -69,7 +64,7 @@ BuildRequires: php-composer(guzzlehttp/psr7) < %{psr7_max_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
-## phpcompatinfo (computed from version 6.2.3)
+## phpcompatinfo (computed from version 6.3.0)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
@@ -90,9 +85,10 @@ Requires: php-composer(guzzlehttp/promises) >= %{promises_min_ver}
Requires: php-composer(guzzlehttp/promises) < %{promises_max_ver}
Requires: php-composer(guzzlehttp/psr7) >= %{psr7_min_ver}
Requires: php-composer(guzzlehttp/psr7) < %{psr7_max_ver}
+# composer.json: optional
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(psr/log) < %{psr_log_max_ver}
-# phpcompatinfo (computed from version 6.2.3)
+# phpcompatinfo (computed from version 6.3.0)
Requires: php-curl
Requires: php-date
Requires: php-filter
@@ -126,9 +122,6 @@ Autoloader: %{phpdir}/GuzzleHttp6/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-# Proxy should not end with /
-%patch0 -p1
-
%build
: Create common autoloader
@@ -172,9 +165,10 @@ sed 's/function testDescribesType/function SKIP_testDescribesType/' \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" php56 php70 php71 php72; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose
fi
done
exit $RETURN_CODE
@@ -192,6 +186,10 @@ exit $RETURN_CODE
%changelog
+* Fri Jun 23 2017 Shawn Iwinski <shawn@iwin.ski> - 6.3.0-1
+- Update to 6.3.0 (RHBZ #1464283)
+- Remove patch
+
* Fri Apr 07 2017 Shawn Iwinski <shawn@iwin.ski> - 6.2.3-1
- Update to 6.2.3
- Fix rawhide (F27) FTBS